]> git.draconx.ca Git - gentoo-draconx.git/blob - media-sound/mpc/mpc-0.15.ebuild
Update moo2-data ebuild for gog updates.
[gentoo-draconx.git] / media-sound / mpc / mpc-0.15.ebuild
1 # Copyright 1999-2009 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: /var/cvsroot/gentoo-x86/media-sound/mpc/mpc-0.15.ebuild,v 1.6 2009/05/17 14:41:10 armin76 Exp $
4
5 inherit bash-completion eutils
6
7 DESCRIPTION="A commandline client for Music Player Daemon (media-sound/mpd)"
8 HOMEPAGE="http://www.musicpd.org"
9 SRC_URI="mirror://sourceforge/musicpd/${P}.tar.bz2"
10
11 LICENSE="GPL-2"
12 SLOT="0"
13 KEYWORDS="amd64 hppa ppc ppc64 sparc x86"
14 IUSE="iconv"
15
16 DEPEND="iconv? ( virtual/libiconv )"
17
18 src_unpack() {
19         unpack ${A};
20
21         cd "${S}"
22         epatch ${FILESDIR}/${P}-playid.patch
23 }
24
25 src_compile() {
26         econf --disable-dependency-tracking \
27                 $(use_enable iconv)
28         emake || die "emake failed"
29 }
30
31 src_install() {
32         emake install DESTDIR="${D}" || die "emake install failed"
33         dodoc AUTHORS NEWS README
34         dodoc doc/mpd-m3u-handler.sh doc/mppledit doc/mpd-pls-handler.sh
35         rm -rf "${D}"/usr/share/doc/${PN}
36         rmdir "${D}"/usr/share/${PN}
37
38         dobashcompletion doc/mpc-bashrc
39 }