]> git.draconx.ca Git - gentoo-draconx.git/blob - x11-libs/libxcb/libxcb-1.7.ebuild
Add xorg-x11 ebuild without nonfree fonts.
[gentoo-draconx.git] / x11-libs / libxcb / libxcb-1.7.ebuild
1 # Copyright 1999-2011 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: /var/cvsroot/gentoo-x86/x11-libs/libxcb/libxcb-1.7.ebuild,v 1.13 2011/06/08 15:48:51 scarabeus Exp $
4
5 EAPI=3
6
7 XORG_EAUTORECONF=yes
8 inherit python xorg-2
9
10 DESCRIPTION="X C-language Bindings library"
11 HOMEPAGE="http://xcb.freedesktop.org/"
12 EGIT_REPO_URI="git://anongit.freedesktop.org/git/xcb/libxcb"
13 [[ ${PV} != 9999* ]] && \
14         SRC_URI="http://xcb.freedesktop.org/dist/${P}.tar.bz2"
15
16 KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 s390 sh sparc x86 ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
17 IUSE="doc selinux"
18
19 RDEPEND="x11-libs/libXau
20         x11-libs/libXdmcp
21         dev-libs/libpthread-stubs
22         >=x11-proto/xcb-proto-1.6"
23 DEPEND="${RDEPEND}
24         doc? ( app-doc/doxygen )
25         dev-libs/libxslt
26         =dev-lang/python-2*[xml]"
27
28         PATCHES=( "${FILESDIR}/${P}-interix.patch"
29                 "${FILESDIR}/0001-xcb_auth-Fix-memory-leak-in-_xcb_get_auth_info.patch")
30
31 pkg_setup() {
32         python_set_active_version 2
33         xorg-2_pkg_setup
34         XORG_CONFIGURE_OPTIONS=(
35                 $(use_enable doc build-docs)
36                 $(use_enable selinux)
37                 --enable-xinput
38         )
39 }