]> git.draconx.ca Git - gentoo-draconx.git/blob - sci-electronics/slotifier/slotifier-1.1.ebuild
Add ebuild for slotifier.
[gentoo-draconx.git] / sci-electronics / slotifier / slotifier-1.1.ebuild
1 # Copyright © 2021 Nick Bowler
2 # License GPLv3+: GNU General Public License version 3 or any later version.
3 # This is free software: you are free to change and redistribute it.
4 # There is NO WARRANTY, to the extent permitted by law.
5
6 EAPI=7
7
8 DESCRIPTION="Convert overlapping drill hits to Excellon G85 drill slots"
9 HOMEPAGE="http://draconx.ca/projects/slotifier/"
10 SRC_URI="http://draconx.ca/archive/$PN/$P.tar.xz"
11
12 LICENSE="GPL-3+"
13 SLOT="0"
14 KEYWORDS="~amd64 ~x86"
15 IUSE="nls"
16
17 BDEPEND="virtual/pkgconfig"
18 DEPEND="nls? ( virtual/libintl )
19         >=sci-electronics/gerbv-2.7.0
20         sci-libs/neartree"
21 RDEPEND=$DEPEND
22
23 src_configure () {
24         econf $(use_enable nls)
25 }