]> git.draconx.ca Git - gentoo-draconx.git/blob - app-misc/ps2emu/ps2emu-1.0.1-r1.ebuild
app-misc/ps2emu: Update for EAPI 8.
[gentoo-draconx.git] / app-misc / ps2emu / ps2emu-1.0.1-r1.ebuild
1 # Copyright © 2015, 2022 Nick Bowler
2 # License GPLv3+: GNU General Public License version 3 or any later version.
3 # This is free software: you are free to change and redistribute it.
4 # There is NO WARRANTY, to the extent permitted by law.
5
6 EAPI=8
7
8 inherit autotools
9
10 DESCRIPTION="Tools for recording and playing back PS/2 devices on Linux"
11 HOMEPAGE="https://github.com/Lyude/ps2emu"
12 SRC_URI="https://github.com/Lyude/ps2emu/archive/v$PV.tar.gz -> $P.tar.gz"
13
14 LICENSE="GPL-2+"
15 SLOT="0"
16 KEYWORDS="~amd64"
17
18 RDEPEND="dev-libs/glib:2"
19 DEPEND=$RDEPEND
20 BEPEND="virtual/pkgconfig"
21
22 src_prepare() {
23         cp "$FILESDIR/userio.h" ps2emu-kmod/
24
25         default
26         eautoreconf
27 }