]> git.draconx.ca Git - gentoo-draconx.git/blob - media-sound/regainer/regainer-20200826-r1.ebuild
app-portage/squashmirror: Update PYTHON_COMPAT.
[gentoo-draconx.git] / media-sound / regainer / regainer-20200826-r1.ebuild
1 # Copyright 2018,2020 Nick Bowler
2 # License GPLv3+: GNU General Public License version 3 or any later version.
3 # This is free software: you are free to change and redistribute it.
4 # There is NO WARRANTY, to the extent permitted by law.
5
6 EAPI=7
7
8 PYTHON_COMPAT=( python3_{5..8} )
9
10 inherit python-r1
11
12 SHA1=d8c1e9c3d769fbd64953917a183ae9e233bb8f41
13
14 DESCRIPTION="Simple tool which adds ReplayGain tags to your files"
15 HOMEPAGE="https://github.com/kepstin/regainer"
16 SRC_URI="https://github.com/kepstin/$PN/archive/$SHA1.tar.gz -> $P.tar.gz"
17
18 LICENSE="MIT"
19 SLOT="0"
20 KEYWORDS="~amd64 ~x86"
21 REQUIRED_USE="$PYTHON_REQUIRED_USE"
22
23 S=$WORKDIR/$PN-$SHA1
24
25 RDEPEND="$PYTHON_DEPS
26         media-libs/mutagen[$PYTHON_USEDEP]
27         media-video/ffmpeg[encode]"
28 DEPEND="$PYTHON_DEPS"
29
30 src_install () {
31         default
32
33         python_foreach_impl python_newscript regainer.py regainer
34 }