]> git.draconx.ca Git - gentoo-draconx.git/blob - sci-electronics/lepton-eda/lepton-eda-1.9.11_p20200604.ebuild
Add ebuild for lepton-eda.
[gentoo-draconx.git] / sci-electronics / lepton-eda / lepton-eda-1.9.11_p20200604.ebuild
1 # Copyright © 2020 Nick Bowler
2 # License GPLv3+: GNU General Public License version 3 or any later version.
3 # This is free software: you are free to change and redistribute it.
4 # There is NO WARRANTY, to the extent permitted by law.
5
6 EAPI=7
7
8 inherit xdg-utils
9
10 MY_P=$PN-${PV%_p*}
11
12 DESCRIPTION="Schematic capture and netlist utilities (fork of gEDA:gaf)"
13 HOMEPAGE="https://github.com/lepton-eda/lepton-eda"
14 SRC_URI="$HOMEPAGE/releases/download/${PV/_p/-}/$MY_P.tar.gz"
15
16 LICENSE="GPL-2+"
17 SLOT="0"
18 KEYWORDS="~amd64 ~x86"
19 IUSE="doc nls stroke"
20
21 RDEPEND=">=dev-scheme/guile-2.0
22         >=x11-libs/gtk+-2.24:2
23         nls? ( virtual/libintl )
24         stroke? ( dev-libs/libstroke )"
25 DEPEND="$RDEPEND
26         doc? ( app-doc/doxygen )
27         nls? ( >=sys-devel/gettext-0.18 )
28         dev-util/desktop-file-utils
29         x11-misc/shared-mime-info
30         sys-apps/groff
31         virtual/pkgconfig"
32
33 S=$WORKDIR/$MY_P
34
35 src_configure () {
36         econf \
37                 $(use_enable doc doxygen) \
38                 $(use_enable nls) \
39                 $(use_with stroke libstroke) \
40                 --disable-update-xdg-database \
41                 --disable-rpath
42 }
43
44 pkg_postinst () {
45         xdg_desktop_database_update
46         xdg_mimeinfo_database_update
47         xdg_icon_cache_update
48 }
49
50 pkg_postrm () {
51         pkg_postinst
52 }