]> git.draconx.ca Git - gentoo-draconx.git/blob - app-crypt/acme-client/acme-client-1.3.1.ebuild
app-crypt/acme-client: New package.
[gentoo-draconx.git] / app-crypt / acme-client / acme-client-1.3.1.ebuild
1 # Copyright © 2022 Nick Bowler
2 # License GPLv3+: GNU General Public License version 3 or any later version.
3 # This is free software: you are free to change and redistribute it.
4 # There is NO WARRANTY, to the extent permitted by law.
5
6 EAPI=8
7
8 inherit autotools
9
10 DESCRIPTION="C-based ACME client ported from OpenBSD"
11 HOMEPAGE="https://sr.ht/~graywolf/acme-client-portable/"
12 SRC_URI="https://data.wolfsden.cz/sources/$P.tar.gz"
13
14 LICENSE="GPL-2"
15 SLOT="0"
16 KEYWORDS="~amd64"
17
18 RDEPEND="dev-libs/openssl"
19 DEPEND="virtual/yacc
20         $RDEPEND"
21
22 PATCHES=(
23         "$FILESDIR/$P-no-default-lto.patch"
24         "$FILESDIR/$P-allow-nonroot.patch"
25         "$FILESDIR/$P-allow-group-permissions.patch"
26         "$FILESDIR/$P-support-must-staple.patch"
27 )
28
29 src_prepare () {
30         default
31         eautoreconf
32 }
33
34 src_install () {
35         dodoc "$FILESDIR/acme-client.conf.example"
36
37         default
38 }