]> git.draconx.ca Git - gentoo-draconx.git/blob - x11-drivers/xf86-video-intel/xf86-video-intel-2.10.903.ebuild
Add mesa-7.7.1_rc2 with i915kill patch.
[gentoo-draconx.git] / x11-drivers / xf86-video-intel / xf86-video-intel-2.10.903.ebuild
1 # Copyright 1999-2010 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: /var/cvsroot/gentoo-x86/x11-drivers/xf86-video-intel/xf86-video-intel-2.10.0-r1.ebuild,v 1.2 2010/03/14 22:42:25 remi Exp $
4
5 EAPI=3
6
7 inherit linux-info xorg-2
8
9 DESCRIPTION="X.Org driver for Intel cards"
10
11 KEYWORDS="~amd64 ~ia64 ~x86 ~x86-fbsd"
12 IUSE="dri"
13
14 RDEPEND=">=x11-base/xorg-server-1.6
15         >=x11-libs/libdrm-2.4.16
16         x11-libs/libpciaccess
17         x11-libs/libXext
18         x11-libs/libXfixes
19         x11-libs/libXvMC
20         >=x11-libs/libxcb-1.5"
21 DEPEND="${RDEPEND}
22         >=x11-proto/dri2proto-1.99.3
23         x11-proto/fontsproto
24         x11-proto/randrproto
25         x11-proto/renderproto
26         x11-proto/xextproto
27         x11-proto/xineramaproto
28         x11-proto/xproto
29         dri? ( x11-proto/xf86driproto
30                x11-proto/glproto )"
31
32 PATCHES=(
33 )
34
35 pkg_setup() {
36         xorg-2_pkg_setup
37         CONFIGURE_OPTIONS="$(use_enable dri) --enable-xvmc"
38 }
39
40 pkg_postinst() {
41         if linux_config_exists \
42                 && ! linux_chkconfig_present CONFIG_DRM_I915_KMS; then
43                 echo
44                 ewarn "This driver requires KMS support in your kernel"
45                 ewarn "  Device Drivers --->"
46                 ewarn "    Graphics support --->"
47                 ewarn "      Direct Rendering Manager (XFree86 4.1.0 and higher DRI support)  --->"
48                 ewarn "      <*>   Intel 830M, 845G, 852GM, 855GM, 865G (i915 driver)  --->"
49                 ewarn "              i915 driver"
50                 ewarn "      [*]       Enable modesetting on intel by default"
51                 echo
52         fi
53 }