]> git.draconx.ca Git - gentoo-draconx.git/blob - x11-apps/dragon/dragon-1.1.1.ebuild
x11-apps/dragon: Fix ebuild copyright.
[gentoo-draconx.git] / x11-apps / dragon / dragon-1.1.1.ebuild
1 # Copyright © 2020 Nick Bowler
2 # License GPLv3+: GNU General Public License version 3 or any later version.
3 # This is free software: you are free to change and redistribute it.
4 # There is NO WARRANTY, to the extent permitted by law.
5
6 EAPI=7
7
8 inherit toolchain-funcs
9
10 DESCRIPTION="Simple drag and drop source/target for X"
11 HOMEPAGE="https://github.com/mwh/dragon"
12 SRC_URI="https://github.com/mwh/dragon/archive/v$PV.tar.gz -> $P.tar.gz"
13
14 LICENSE="GPL-3+"
15 SLOT="0"
16 KEYWORDS="~amd64 ~x86"
17
18 DEPEND="x11-libs/gtk+:3"
19 RDEPEND="$DEPEND"
20
21 src_prepare () {
22         cat >GNUmakefile <<'EOF'
23 GTK_CFLAGS := $(shell pkg-config --cflags gtk+-3.0)
24
25 ALL_CPPFLAGS := -std=c99 -Wall $(filter -D% -I%,$(GTK_CFLAGS)) $(CPPFLAGS)
26 ALL_CFLAGS := -std=c99 -Wall $(filter-out -D% -I%,$(GTK_CFLAGS)) $(CFLAGS)
27 LIBS := $(shell pkg-config --libs gtk+-3.0)
28
29 dragon: dragon.o
30         $(CC) $(ALL_CFLAGS) $(LDFLAGS) -o $@ $^ $(LIBS)
31
32 .c.o:
33         $(CC) $(ALL_CPPFLAGS) $(ALL_CFLAGS) -c -o $@ $<
34 EOF
35         default
36 }
37
38 src_compile () {
39         emake CC=$(tc-getCC)
40 }
41
42 src_install () {
43         dobin dragon
44         dodoc README
45 }