]> git.draconx.ca Git - gentoo-draconx.git/blob - media-plugins/gimp-resynthesizer/gimp-resynthesizer-2.0.3-r7.ebuild
media-plugins/gimp-python: Remove python eclass usage.
[gentoo-draconx.git] / media-plugins / gimp-resynthesizer / gimp-resynthesizer-2.0.3-r7.ebuild
1 # Copyright © 2020-2022 Nick Bowler
2 # License GPLv3+: GNU General Public License version 3 or any later version.
3 # This is free software: you are free to change and redistribute it.
4 # There is NO WARRANTY, to the extent permitted by law.
5
6 EAPI=8
7
8 inherit autotools
9
10 MY_PN=${PN#gimp-}
11 MY_P=$MY_PN-$PV
12
13 DESCRIPTION="Suite of GIMP plugins for texture synthesis"
14 HOMEPAGE="https://github.com/bootchk/resynthesizer"
15 SRC_URI="https://github.com/bootchk/resynthesizer/archive/v$PV.tar.gz -> $MY_P.tar.gz"
16
17 LICENSE="GPL-3+"
18 SLOT="0"
19 KEYWORDS="~amd64"
20
21 RDEPEND="dev-lang/python:2.7
22         || (
23                 media-plugins/gimp-python[python_targets_python2_7(+)]
24                 media-gfx/gimp[python(-)] )"
25
26 S=$WORKDIR/$MY_P
27
28 src_prepare () {
29         default
30         eautoreconf
31 }