]> git.draconx.ca Git - gentoo-draconx.git/blob - media-plugins/gimp-plugin-export-layers/gimp-plugin-export-layers-3.3.1-r4.ebuild
media-plugins/gimp-python: Remove python eclass usage.
[gentoo-draconx.git] / media-plugins / gimp-plugin-export-layers / gimp-plugin-export-layers-3.3.1-r4.ebuild
1 # Copyright © 2020-2022 Nick Bowler
2 # License GPLv3+: GNU General Public License version 3 or any later version.
3 # This is free software: you are free to change and redistribute it.
4 # There is NO WARRANTY, to the extent permitted by law.
5
6 EAPI=7
7
8 DESCRIPTION="GIMP plug-in that exports layers as separate images"
9 HOMEPAGE="https://khalim19.github.io/gimp-plugin-export-layers/"
10 SRC_URI="https://github.com/khalim19/$PN/archive/$PV.tar.gz -> $P.tar.gz"
11
12 LICENSE="GPL-3+"
13 SLOT="0"
14 KEYWORDS="~amd64 ~x86"
15
16 RDEPEND="dev-lang/python:2.7
17         || (
18                 media-plugins/gimp-python[python_targets_python2_7(+)]
19                 media-gfx/gimp[python(-)] )"
20 BDEPEND="dev-lang/python:2.7"
21
22 src_install () {
23         local plugindir=/usr/$(get_libdir)/gimp/2.0/plug-ins
24
25         default
26
27         insinto "$plugindir"
28         doins -r export_layers
29
30         local args=(
31                 -m compileall -q -f -d "${EPREFIX%/}$plugindir" "${ED%/}$plugindir"
32         )
33         python2.7 "${args[@]}"
34         python2.7 -OO "${args[@]}"
35
36         exeinto "$plugindir"
37         doexe export_layers.py
38 }