]> git.draconx.ca Git - gentoo-draconx.git/blob - app-text/xpdf/xpdf-3.04-r2.ebuild
app-text/xpdf-3.04: Fix SRC_URI and prefixed installation.
[gentoo-draconx.git] / app-text / xpdf / xpdf-3.04-r2.ebuild
1 # Copyright © 2012, 2014-2015, 2020 Nick Bowler
2 # License GPLv3+: GNU General Public License version 3 or any later version.
3 # This is free software: you are free to change and redistribute it.
4 # There is NO WARRANTY, to the extent permitted by law.
5
6 EAPI=7
7
8 inherit desktop xdg
9
10 DESCRIPTION="An X viewer for PDF files"
11 HOMEPAGE="http://www.foolabs.com/xpdf/"
12 SRC_URI="https://xpdfreader-dl.s3.amazonaws.com/old/$P.tar.gz"
13
14 LICENSE="|| ( GPL-2 GPL-3 )"
15 SLOT="0"
16 KEYWORDS="~amd64"
17
18 DEPEND=">=x11-libs/motif-2.3:0
19         media-libs/freetype:2
20         app-text/libpaper
21         x11-libs/libX11
22         x11-libs/libXpm"
23 RDEPEND="$DEPEND
24         media-fonts/urw-fonts"
25
26 PATCHES=("$FILESDIR/xpdf-Add-Gentoo-font-path.patch")
27
28 src_configure() {
29         econf --with-freetype2-includes=${EROOT%/}/usr/include/freetype2
30 }
31
32 src_install() {
33         dobin xpdf/xpdf
34         doman doc/xpdf.1
35         doman doc/xpdfrc.5
36         dodoc README ANNOUNCE CHANGES
37         newicon xpdf/xpdfIcon.xpm xpdf.xpm
38
39         insinto /etc
40         newins doc/sample-xpdfrc xpdfrc
41         newdoc doc/sample-xpdfrc xpdfrc.example
42
43         insinto /usr/share/applications
44         doins "$FILESDIR/xpdf.desktop"
45 }