]> git.draconx.ca Git - gentoo-draconx.git/blob - media-sound/regainer/regainer-20191117.ebuild
regainer: Bump and update PYTHON_COMPAT.
[gentoo-draconx.git] / media-sound / regainer / regainer-20191117.ebuild
1 # Copyright 2018,2020 Nick Bowler
2 # License GPLv3+: GNU General Public License version 3 or later.
3 # There is NO WARRANTY, to the extent permitted by law.
4
5 EAPI=7
6
7 PYTHON_COMPAT=( python3_5 python3_6 python3_7 )
8
9 inherit python-r1
10
11 SHA1=da6411506b92113a517d1a2bc80027c2dfb92cb4
12
13 DESCRIPTION="Simple tool which adds ReplayGain tags to your files"
14 HOMEPAGE="https://github.com/kepstin/regainer"
15 SRC_URI="https://github.com/kepstin/$PN/archive/$SHA1.tar.gz -> $P.tar.gz"
16
17 LICENSE="MIT"
18 SLOT="0"
19 KEYWORDS="~amd64 ~x86"
20 REQUIRED_USE="$PYTHON_REQUIRED_USE"
21
22 S=$WORKDIR/$PN-$SHA1
23
24 RDEPEND="$PYTHON_DEPS
25         media-libs/mutagen[$PYTHON_USEDEP]
26         media-video/ffmpeg[encode]"
27 DEPEND="$PYTHON_DEPS"
28
29 src_install () {
30         default
31
32         python_foreach_impl python_newscript regainer.py regainer
33 }