]> git.draconx.ca Git - gentoo-draconx.git/blob - media-fonts/mplus-t-fonts/mplus-t-fonts-20140706.ebuild
Add ebuild to generate M+ terminal fonts.
[gentoo-draconx.git] / media-fonts / mplus-t-fonts / mplus-t-fonts-20140706.ebuild
1 # Copyright © 2014 Nick Bowler
2 # License GPLv3+: GNU General Public License version 3 or later.
3 # There is NO WARRANTY, to the extent permitted by law.
4
5 EAPI=5
6 PYTHON_COMPAT=( python2_7 )
7
8 inherit python-any-r1 font
9
10 SHA1=d180c0bfdd4e3911a18360b3ccacd5271441e240
11
12 DESCRIPTION="Variant of the M+ fonts with enlarged CJK glyphs"
13 SRC_URI="http://git.draconx.ca/gitweb/scripts.git/snapshot/$SHA1.tar.xz"
14
15 LICENSE="WTFPL-2 mplus-fonts IPAfont"
16 SLOT="0"
17 KEYWORDS="~amd64"
18
19 DEPEND="$PYTHON_DEPS
20         media-fonts/mplus-outline-fonts[ipafont]
21         media-gfx/fontforge[python]"
22
23 S=$WORKDIR/$SHA1
24 MPLUSDIR=$EPREFIX/usr/share/fonts/mplus-outline-fonts
25
26 FONT_S=$S/inst
27 FONT_SUFFIX=ttf
28
29 pkg_setup() {
30         python-any-r1_pkg_setup
31         font_pkg_setup
32 }
33
34 src_compile() {
35         ln -s "$MPLUSDIR"/*.ttf . || die
36         python mplus-t-gen.py || die
37
38         mkdir inst
39         mv M+?T+IPAG.ttf inst
40 }