]> git.draconx.ca Git - gentoo-draconx.git/blob - net-mail/notmuchfs/notmuchfs-0.1_p20140226.ebuild
Add notmuchfs ebuild.
[gentoo-draconx.git] / net-mail / notmuchfs / notmuchfs-0.1_p20140226.ebuild
1 # Copyright © 2015-2016 Nick Bowler
2 # License GPLv3+: GNU General Public License version 3 or later.
3 # There is NO WARRANTY, to the extent permitted by law.
4
5 EAPI=6
6
7 inherit toolchain-funcs
8
9 SHA1=1f34bc6d30fdffb98ad98387c93a8a5824703639
10
11 DESCRIPTION="Virtual maildir filesystem for notmuch queries"
12 HOMEPAGE="https://github.com/tsto/notmuchfs/"
13 SRC_URI="https://github.com/tsto/notmuchfs/archive/$SHA1.tar.gz"
14
15 LICENSE="GPL-3+"
16 SLOT="0"
17 KEYWORDS="~amd64"
18
19 DEPEND="net-mail/notmuch
20         sys-fs/fuse"
21 RDEPEND=$DEPEND
22
23 S=$WORKDIR/$PN-$SHA1
24
25 PATCHES=(
26         "$FILESDIR/$PN-fix-build.patch"
27         )
28
29 src_compile() {
30         emake CC=$(tc-getCC)
31 }
32
33 src_install() {
34         dobin notmuchfs
35         dodoc README.md README.MUTT.md ISSUES
36         newdoc mutt/.muttrc muttrc.example
37 }