]> git.draconx.ca Git - gentoo-draconx.git/blob - dev-embedded/teensy_loader_cli/teensy_loader_cli-2.1.ebuild
Add dev-embedded/teensy_loader_cli ebuild.
[gentoo-draconx.git] / dev-embedded / teensy_loader_cli / teensy_loader_cli-2.1.ebuild
1 # Copyright © 2020 Nick Bowler
2 # License GPLv3+: GNU General Public License version 3 or any later version.
3 # This is free software: you are free to change and redistribute it.
4 # There is NO WARRANTY, to the extent permitted by law.
5
6 EAPI=7
7
8 inherit toolchain-funcs
9
10 DESCRIPTION="Command-line program loader for Teensy"
11 HOMEPAGE="https://www.pjrc.com/teensy/loader_cli.html"
12 SRC_URI="https://github.com/PaulStoffregen/$PN/archive/$PV.tar.gz -> $P.tar.gz"
13
14 LICENSE="GPL-3"
15 SLOT="0"
16 KEYWORDS="~amd64 ~x86"
17 IUSE="examples"
18
19 DEPEND="virtual/libusb:0"
20 RDEPEND=$DEPEND
21
22 src_compile () {
23         emake CC="$(tc-getCC)" CFLAGS="$LDFLAGS $CFLAGS"
24 }
25
26 src_install () {
27         dobin teensy_loader_cli
28
29         if use examples; then
30                 docompress -x "/usr/share/doc/$PF/examples"
31                 docinto examples
32                 dodoc *.hex
33         fi
34 }