]> git.draconx.ca Git - gentoo-draconx.git/blob - dev-util/cdecl99/cdecl99-1.3.ebuild
dev-util/cdecl99: Fix 1.3 build when /bin/sh is bash-5.
[gentoo-draconx.git] / dev-util / cdecl99 / cdecl99-1.3.ebuild
1 # Copyright © 2021-2022, 2024 Nick Bowler
2 # License GPLv3+: GNU General Public License version 3 or any later version.
3 # This is free software: you are free to change and redistribute it.
4 # There is NO WARRANTY, to the extent permitted by law.
5
6 EAPI=7
7
8 inherit multiprocessing unpacker
9
10 DESCRIPTION="Explain and construct C declarations"
11 HOMEPAGE="http://draconx.ca/projects/cdecl99/"
12 SRC_URI="http://draconx.ca/archive/$PN/$P.tar.lz"
13
14 LICENSE="GPL-3+"
15 SLOT="0"
16 KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~sparc ~x86"
17 IUSE="static-libs nls readline"
18
19 RDEPEND="nls? ( virtual/libintl sys-devel/bison[nls] )
20         readline? ( sys-libs/readline:= )"
21 DEPEND="$RDEPEND"
22
23 PATCHES=(
24         "$FILESDIR/$P-bash5-fix.patch"
25 )
26
27 src_configure () {
28         econf \
29                 --enable-shared $(use_enable static-libs static) \
30                 $(use_with readline) \
31                 $(use_enable nls)
32 }
33
34 src_install () {
35         default
36
37         use static-libs || find "$ED" -name '*.la' -delete
38 }
39
40 src_test () {
41         emake TESTSUITEFLAGS="-j$(makeopts_jobs)" check
42 }