]> git.draconx.ca Git - gentoo-draconx.git/blob - games-puzzle/spacechem-bin/spacechem-bin-1012.1.ebuild
Add games-puzzle/spacechem-bin.
[gentoo-draconx.git] / games-puzzle / spacechem-bin / spacechem-bin-1012.1.ebuild
1 # Copyright 1999-2009 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: /var/cvsroot/gentoo-x86/games-strategy/darwinia-demo/darwinia-demo-1.3.0.ebuild,v 1.9 2009/05/22 21:47:48 mr_bones_ Exp $
4
5 EAPI="2"
6
7 inherit eutils games
8
9 DESCRIPTION="A design-based puzzle game from Zachtronics Industries."
10 HOMEPAGE="http://www.spacechemthegame.com/"
11
12 MY_PN="SpaceChem"
13 MY_P="${MY_PN}-${PV//./-}"
14 SRC_URI="${MY_P}-hib.tar.gz"
15
16 LICENSE="spacechem"
17 SLOT="0"
18 KEYWORDS="-* amd64 x86"
19 IUSE=""
20 RESTRICT="fetch strip"
21
22 RDEPEND=">=dev-lang/mono-2
23          x11-misc/xclip
24          media-libs/libsdl
25          media-libs/sdl-mixer
26          media-libs/sdl-image"
27
28 pkg_nofetch() {
29     einfo "Please download ${SRC_URI} from the link you received by e-mail"
30     einfo "when you purchased ${MY_PN} and place it in ${DISTDIR}"
31 }
32
33 S=${WORKDIR}
34
35 src_unpack() {
36         unpack "${A}"
37         cd "${S}"
38         unpack "./${MY_PN}-i386.deb"
39         unpack ./data.tar.gz
40 }
41
42 src_install() {
43         dodir "/${GAMES_PREFIX_OPT}/${PN}/"
44         cd "${S}/opt/zachtronicsindustries/spacechem/"
45
46         cp -R . "${D}/${GAMES_PREFIX_OPT}/${PN}"
47
48         newicon icon.png "${PN}.png"
49         games_make_wrapper "${PN}" "mono SpaceChem.exe" "${ROOT}/${GAMES_PREFIX_OPT}/${PN}/"
50         make_desktop_entry "${PN}" "SpaceChem" "${PN}" "Game;LogicGame;" "Comment=Solve design-based challenges in this game from Zachtronics Industries"
51
52         prepgamesdirs
53 }