]> git.draconx.ca Git - gentoo-draconx.git/blob - media-video/aegisub/aegisub-2.1.9_pre5585.ebuild
Update Xpdf manifest.
[gentoo-draconx.git] / media-video / aegisub / aegisub-2.1.9_pre5585.ebuild
1 # Copyright 1999-2011 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 EAPI="4"
6
7 WX_GTK_VER="2.8"
8 inherit autotools eutils wxwidgets
9
10 DESCRIPTION="Advanced SSA/ASS subtitle editor"
11 HOMEPAGE="http://www.aegisub.net/"
12 SRC_URI="http://rion-overlay.googlecode.com/files/${P}.tar.xz"
13
14 LICENSE="GPL-2"
15 SLOT="0"
16 KEYWORDS="~amd64 ~x86"
17 IUSE="alsa debug +ffmpeg lua nls openal oss portaudio pulseaudio spell"
18
19 RDEPEND="
20         x11-libs/wxGTK:${WX_GTK_VER}[X,opengl,debug?]
21         virtual/opengl
22         virtual/glu
23         >=media-libs/libass-0.9.11[fontconfig]
24         virtual/libiconv
25         >=media-libs/fontconfig-2.4.2
26         media-libs/freetype:2
27
28         alsa? ( media-libs/alsa-lib )
29         portaudio? ( =media-libs/portaudio-19* )
30         pulseaudio? ( media-sound/pulseaudio )
31         openal? ( media-libs/openal )
32
33         lua? ( >=dev-lang/lua-5.1.1 )
34
35         spell? ( >=app-text/hunspell-1.2 )
36         ffmpeg? ( >=media-libs/ffmpegsource-2.13.1 )
37 "
38 DEPEND="${RDEPEND}
39         dev-util/intltool
40         dev-util/pkgconfig
41         media-gfx/imagemagick
42 "
43
44 src_prepare() {
45         sh autogen.sh --skip-configure
46         eautoreconf
47 }
48
49 src_configure() {
50         econf \
51                 $(use_with alsa) \
52                 $(use_with oss) \
53                 $(use_with portaudio) \
54                 $(use_with pulseaudio) \
55                 $(use_with openal) \
56                 $(use_with lua) \
57                 $(use_with ffmpeg ffms) \
58                 $(use_with spell hunspell) \
59                 $(use_enable debug) \
60                 $(use_enable nls)
61 }