]> git.draconx.ca Git - gentoo-draconx.git/blob - media-fonts/mplus-t-fonts/mplus-t-fonts-20140706-r1.ebuild
mplus-t-fonts: Add ~arm keywords
[gentoo-draconx.git] / media-fonts / mplus-t-fonts / mplus-t-fonts-20140706-r1.ebuild
1 # Copyright © 2014, 2018 Nick Bowler
2 # License GPLv3+: GNU General Public License version 3 or later.
3 # There is NO WARRANTY, to the extent permitted by law.
4
5 EAPI=6
6 PYTHON_COMPAT=( python2_7 )
7
8 inherit python-any-r1 font
9
10 SHA1=d180c0bfdd4e3911a18360b3ccacd5271441e240
11
12 DESCRIPTION="Variant of the M+ fonts with enlarged CJK glyphs"
13 SRC_URI="https://git.draconx.ca/gitweb/scripts.git/snapshot/$SHA1.tar.xz
14          -> scripts-$SHA1.tar.xz"
15
16 LICENSE="WTFPL-2 mplus-fonts IPAfont"
17 SLOT="0"
18 KEYWORDS="~amd64 ~arm"
19
20 DEPEND="$(python_gen_any_dep 'media-gfx/fontforge[python,${PYTHON_USEDEP}]')
21         media-fonts/mplus-outline-fonts[ipafont]"
22
23 python_check_deps () {
24         has_version "media-gfx/fontforge[${PYTHON_USEDEP}]"
25 }
26
27 S=$WORKDIR/$SHA1
28 MPLUSDIR=$EPREFIX/usr/share/fonts/mplus-outline-fonts
29
30 FONT_S=$S/inst
31 FONT_SUFFIX=ttf
32
33 pkg_setup () {
34         python-any-r1_pkg_setup
35         font_pkg_setup
36 }
37
38 src_compile () {
39         ln -s "$MPLUSDIR"/*.ttf . || die
40         python mplus-t-gen.py || die
41
42         mkdir inst
43         mv M+?T+IPAG.ttf inst
44 }