]> git.draconx.ca Git - gentoo-draconx.git/blobdiff - app-text/docbook-mathml-dtd/docbook-mathml-dtd-1.1_rc1-r2.ebuild
app-text/mathml2: Rewrite of mathml-xml-dtd.
[gentoo-draconx.git] / app-text / docbook-mathml-dtd / docbook-mathml-dtd-1.1_rc1-r2.ebuild
similarity index 91%
rename from app-text/docbook-mathml-dtd/docbook-mathml-dtd-1.1_rc1-r1.ebuild
rename to app-text/docbook-mathml-dtd/docbook-mathml-dtd-1.1_rc1-r2.ebuild
index 37188a64825a3462d5c5f3a2bf692100eb4e9072..d251b3da66ef6197dbea7605c26858a8cf4c68aa 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright © 2020 Nick Bowler
+# Copyright © 2020-2021 Nick Bowler
 # License GPLv3+: GNU General Public License version 3 or any later version.
 # This is free software: you are free to change and redistribute it.
 # There is NO WARRANTY, to the extent permitted by law.
@@ -23,7 +23,7 @@ S=$WORKDIR
 
 RDEPEND="dev-libs/libxml2
        app-text/docbook-xml-dtd:4.3
-       app-text/mathml-xml-dtd"
+       app-text/mathml2"
 
 src_unpack () {
        cp "$DISTDIR/$A" "$S" || die
@@ -42,12 +42,12 @@ src_install () {
 
        insinto /etc/sgml
        newins - mathml-docbook-$PV.cat <<-EOF
-               CATALOG "${EPREFIX#/}$insdir/catalog"
+               CATALOG "${EPREFIX%/}$insdir/catalog"
        EOF
 }
 
 update_catalog () {
-       local insdir="file://${EPREFIX#/}/usr/share/sgml/docbook/${P#docbook-}"
+       local insdir="file://${EPREFIX%/}/usr/share/sgml/docbook/${P#docbook-}"
        local xmlcatalog="${BROOT%/}/usr/bin/xmlcatalog"
 
        local dtdpublic="-//OASIS//DTD DocBook MathML Module V$DTDVER//EN"