]> git.draconx.ca Git - gentoo-draconx.git/blobdiff - app-text/xpdf/xpdf-3.04-r2.ebuild
app-text/xpdf-3.04: Fix SRC_URI and prefixed installation.
[gentoo-draconx.git] / app-text / xpdf / xpdf-3.04-r2.ebuild
similarity index 62%
rename from app-text/xpdf/xpdf-3.04-r1.ebuild
rename to app-text/xpdf/xpdf-3.04-r2.ebuild
index bb248211dd2f6adc777b2949b6a9041159681430..29fe8f36a211fec84b43c1bf06f65614d1047475 100644 (file)
@@ -1,14 +1,15 @@
-# Copyright © 2012, 2014-2015 Nick Bowler
-# License GPLv3+: GNU General Public License version 3 or later.
+# Copyright © 2012, 2014-2015, 2020 Nick Bowler
+# License GPLv3+: GNU General Public License version 3 or any later version.
+# This is free software: you are free to change and redistribute it.
 # There is NO WARRANTY, to the extent permitted by law.
 
-EAPI=5
+EAPI=7
 
-inherit eutils
+inherit desktop xdg
 
 DESCRIPTION="An X viewer for PDF files"
 HOMEPAGE="http://www.foolabs.com/xpdf/"
-SRC_URI="ftp://ftp.foolabs.com/pub/xpdf/xpdf-3.04.tar.gz"
+SRC_URI="https://xpdfreader-dl.s3.amazonaws.com/old/$P.tar.gz"
 
 LICENSE="|| ( GPL-2 GPL-3 )"
 SLOT="0"
@@ -22,13 +23,10 @@ DEPEND=">=x11-libs/motif-2.3:0
 RDEPEND="$DEPEND
        media-fonts/urw-fonts"
 
-src_prepare() {
-       epatch "$FILESDIR/xpdf-Add-Gentoo-font-path.patch"
-       epatch_user
-}
+PATCHES=("$FILESDIR/xpdf-Add-Gentoo-font-path.patch")
 
 src_configure() {
-       econf --with-freetype2-includes=/usr/include/freetype2
+       econf --with-freetype2-includes=${EROOT%/}/usr/include/freetype2
 }
 
 src_install() {