]> git.draconx.ca Git - gentoo-draconx.git/blobdiff - sys-apps/vbetest/vbetest-0.10.ebuild
games-strategy/uplink: Update to work with latest gentoo repo.
[gentoo-draconx.git] / sys-apps / vbetest / vbetest-0.10.ebuild
index 9e5b7ca40d712c8dd63470893b6995cccebee02c..566fc4ccd979099d6119c53394fd298f822b370f 100644 (file)
@@ -1,8 +1,6 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: $
+EAPI=4
 
-inherit eutils
+inherit eutils toolchain-funcs
 
 S="${WORKDIR}/lrmi-${PV}"
 
@@ -13,15 +11,13 @@ SRC_URI="mirror://sourceforge/lrmi/lrmi-${PV}.tar.gz"
 LICENSE="MIT"
 SLOT="0"
 KEYWORDS="~x86 ~amd64"
-IUSE="+lrmi"
+IUSE="lrmi"
 
 DEPEND="lrmi? ( =sys-libs/lrmi-${PV}* )
        !lrmi? ( dev-libs/libx86 )"
 
-src_unpack() {
-       unpack "${A}"
-       cd "${S}"
-
+src_prepare() {
+       epatch "${FILESDIR}/lrmi-${PV}-ldflags.patch"
        if ! use lrmi ; then
                epatch "${FILESDIR}/${PN}-libx86.patch"
        else
@@ -30,9 +26,9 @@ src_unpack() {
 }
 
 src_compile() {
-       emake CFLAGS="${CFLAGS}" vbetest || die
+       emake CC="$(tc-getCC)" CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}" vbetest
 }
 
 src_install() {
-       dobin vbetest || die "dobin"
+       dobin vbetest
 }