]> git.draconx.ca Git - gentoo-draconx.git/blobdiff - media-plugins/gimp-python/gimp-python-2.10.32.ebuild
media-plugins/gimp-python: Remove python eclass usage.
[gentoo-draconx.git] / media-plugins / gimp-python / gimp-python-2.10.32.ebuild
similarity index 75%
rename from media-plugins/gimp-python/gimp-python-2.10.20-r3.ebuild
rename to media-plugins/gimp-python/gimp-python-2.10.32.ebuild
index 099a47653039d4695c3a7d79b8c3fc04b8a1fd2d..8045319deb27de773fdf8810a135579f7fc288f9 100644 (file)
@@ -1,14 +1,11 @@
-# Copyright © 2020-2021 Nick Bowler
+# Copyright © 2020-2022 Nick Bowler
 # License GPLv3+: GNU General Public License version 3 or any later version.
 # This is free software: you are free to change and redistribute it.
 # There is NO WARRANTY, to the extent permitted by law.
 
-EAPI=7
+EAPI=8
 
-_PYTHON_ALLOW_PY27=1
-PYTHON_COMPAT=( python2_7 )
-
-inherit autotools python-single-r1
+inherit autotools
 
 MY_P=${P/-python/}
 
@@ -23,18 +20,15 @@ IUSE="cpu_flags_ppc_altivec cpu_flags_x86_mmx cpu_flags_x86_sse"
 
 DEPEND="dev-lang/python:2.7
        >=media-gfx/gimp-$PV
-       $(python_gen_cond_dep '
-               >=dev-python/pycairo-1.0.2:2[${PYTHON_USEDEP}]
-               >=dev-python/pygtk-2.10.4:2[${PYTHON_USEDEP}]')
+       >=dev-python/pycairo-1.0.2:2[python_targets_python2_7(+)]
+       >=dev-python/pygtk-2.10.4:2[python_targets_python2_7(+)]
        !media-gfx/gimp[python(-)]"
 RDEPEND=$DEPEND
-REQUIRED_USE=$PYTHON_REQUIRED_USE
 
 S=$WORKDIR/$MY_P
 
 PATCHES=(
-       "$FILESDIR/$PV-no-mypaint-brushes.patch"
-       "$FILESDIR/$PV-configure-fixes.patch"
+       "$FILESDIR/2.10.20-no-mypaint-brushes.patch"
 )
 
 src_prepare () {
@@ -55,6 +49,7 @@ src_configure () {
                $(use_enable cpu_flags_x86_mmx mmx)
                $(use_enable cpu_flags_x86_sse sse)
                --enable-python
+               PYTHON=python2.7
        )
 
        econf "${myconf[@]}"