]> git.draconx.ca Git - gentoo-draconx.git/blobdiff - app-crypt/acme-client/acme-client-1.3.1-r1.ebuild
app-crypt/acme-client: Fix dependencies.
[gentoo-draconx.git] / app-crypt / acme-client / acme-client-1.3.1-r1.ebuild
diff --git a/app-crypt/acme-client/acme-client-1.3.1-r1.ebuild b/app-crypt/acme-client/acme-client-1.3.1-r1.ebuild
new file mode 100644 (file)
index 0000000..dce7a2a
--- /dev/null
@@ -0,0 +1,38 @@
+# Copyright © 2022-2023 Nick Bowler
+# License GPLv3+: GNU General Public License version 3 or any later version.
+# This is free software: you are free to change and redistribute it.
+# There is NO WARRANTY, to the extent permitted by law.
+
+EAPI=8
+
+inherit autotools
+
+DESCRIPTION="C-based ACME client ported from OpenBSD"
+HOMEPAGE="https://sr.ht/~graywolf/acme-client-portable/"
+SRC_URI="https://data.wolfsden.cz/sources/$P.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64"
+
+BDEPEND="app-alternatives/yacc"
+RDEPEND="dev-libs/openssl:0="
+DEPEND=$RDEPEND
+
+PATCHES=(
+       "$FILESDIR/$P-no-default-lto.patch"
+       "$FILESDIR/$P-allow-nonroot.patch"
+       "$FILESDIR/$P-allow-group-permissions.patch"
+       "$FILESDIR/$P-support-must-staple.patch"
+)
+
+src_prepare () {
+       default
+       eautoreconf
+}
+
+src_install () {
+       dodoc "$FILESDIR/acme-client.conf.example"
+
+       default
+}