]> git.draconx.ca Git - gentoo-draconx.git/blobdiff - dev-python/prompt_toolkit/prompt_toolkit-1.0.18.ebuild
net-misc/google-cloud-sdk: New package.
[gentoo-draconx.git] / dev-python / prompt_toolkit / prompt_toolkit-1.0.18.ebuild
diff --git a/dev-python/prompt_toolkit/prompt_toolkit-1.0.18.ebuild b/dev-python/prompt_toolkit/prompt_toolkit-1.0.18.ebuild
new file mode 100644 (file)
index 0000000..290a8c3
--- /dev/null
@@ -0,0 +1,23 @@
+# Copyright © 2022 Nick Bowler
+# License GPLv3+: GNU General Public License version 3 or any later version.
+# This is free software: you are free to change and redistribute it.
+# There is NO WARRANTY, to the extent permitted by law.
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{9..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Library for building powerful interactive command lines in Python"
+HOMEPAGE="https://github.com/prompt-toolkit/python-prompt-toolkit https://pypi.org/project/prompt_toolkit/"
+SRC_URI="mirror://pypi/${PN:0:1}/$PN/$P.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="dev-python/six[$PYTHON_USEDEP]
+       dev-python/wcwidth[$PYTHON_USEDEP]"
+
+distutils_enable_tests pytest