]> git.draconx.ca Git - gentoo-draconx.git/blobdiff - net-libs/libmapi/libmapi-2.3-r1.ebuild
gnome-extra/evolution-mapi: Bump.
[gentoo-draconx.git] / net-libs / libmapi / libmapi-2.3-r1.ebuild
similarity index 71%
rename from net-libs/libmapi/libmapi-2.3.ebuild
rename to net-libs/libmapi/libmapi-2.3-r1.ebuild
index 788e8c177a52007074d3db31aa476b580ae9bf27..07a7fd17def543bfb95f136cf8528230af3b5853 100644 (file)
@@ -1,8 +1,9 @@
-# Copyright © 2016 Nick Bowler
-# License GPLv3+: GNU General Public License version 3 or later.
+# Copyright © 2016, 2022 Nick Bowler
+# License GPLv3+: GNU General Public License version 3 or any later version.
+# This is free software: you are free to change and redistribute it.
 # There is NO WARRANTY, to the extent permitted by law.
 
-EAPI=6
+EAPI=8
 
 inherit autotools
 
@@ -18,13 +19,18 @@ IUSE="cxx"
 SLOT="0"
 
 RDEPEND=">=net-fs/samba-4"
-DEPEND="$RDEPEND"
+DEPEND="dev-util/pidl
+       $RDEPEND"
 
 PATCHES=(
        "$FILESDIR/$P-no-automake.patch"
        "$FILESDIR/$P-no-useless-cflags.patch"
        "$FILESDIR/$P-no-recompile-on-install.patch"
        "$FILESDIR/$P-no-build-tests.patch"
+       "$FILESDIR/$P-configure-bashisms.patch"
+       "$FILESDIR/$P-update-credentials-api.patch"
+       "$FILESDIR/$P-update-ndr-api.patch"
+       "$FILESDIR/$P-fix-pidl-compilation.patch"
 )
 
 S=$WORKDIR/openchange-$MY_P