]> git.draconx.ca Git - gentoo-draconx.git/blobdiff - gnome-extra/evolution-mapi/evolution-mapi-3.44.2.ebuild
gnome-extra/evolution-mapi: Bump.
[gentoo-draconx.git] / gnome-extra / evolution-mapi / evolution-mapi-3.44.2.ebuild
similarity index 72%
rename from gnome-extra/evolution-mapi/evolution-mapi-3.30.5.ebuild
rename to gnome-extra/evolution-mapi/evolution-mapi-3.44.2.ebuild
index bb5d3ae50f6bdbe71c0a070dbef2b2fc47f901b4..909031ac41446437094837733dca1ca0662c3918 100644 (file)
@@ -1,10 +1,11 @@
-# Copyright © 2016, 2018-2019 Nick Bowler
+# Copyright © 2016, 2018-2019, 2022 Nick Bowler
 # License GPLv3+: GNU General Public License version 3 or any later version.
+# This is free software: you are free to change and redistribute it.
 # There is NO WARRANTY, to the extent permitted by law.
 
-EAPI=6
+EAPI=8
 
-inherit cmake-utils gnome2
+inherit gnome2 cmake
 
 DESCRIPTION="Evolution module for connecting to Microsoft Exchange"
 HOMEPAGE="https://wiki.gnome.org/Apps/Evolution"
@@ -22,7 +23,7 @@ DEPEND="$RDEPEND
        virtual/pkgconfig"
 
 src_prepare () {
-       cmake-utils_src_prepare
+       cmake_src_prepare
 
        # Both cmake-utils_src_prepare and gnome2_src_prepare call default, which
        # means patches get applied twice and that doesn't end well.  So redefine
@@ -30,19 +31,3 @@ src_prepare () {
        default () { :; }
        gnome2_src_prepare
 }
-
-src_configure () {
-       cmake-utils_src_configure
-}
-
-src_compile () {
-       cmake-utils_src_compile
-}
-
-src_test () {
-       cmake-utils_src_test
-}
-
-src_install () {
-       cmake-utils_src_install
-}