]> git.draconx.ca Git - gentoo-draconx.git/blobdiff - media-plugins/gimp-python/gimp-python-2.10.20-r1.ebuild
Work around python-r1 eclass dropping python2.
[gentoo-draconx.git] / media-plugins / gimp-python / gimp-python-2.10.20-r1.ebuild
similarity index 92%
rename from media-plugins/gimp-python/gimp-python-2.10.20.ebuild
rename to media-plugins/gimp-python/gimp-python-2.10.20-r1.ebuild
index f77a72b0d660cb3a18df4e520d351832a0fae105..300c7863f2cf387cb1774e23a45e7cefdfc56dc1 100644 (file)
@@ -1,10 +1,11 @@
-# Copyright © 2020 Nick Bowler
+# Copyright © 2020-2021 Nick Bowler
 # License GPLv3+: GNU General Public License version 3 or any later version.
 # This is free software: you are free to change and redistribute it.
 # There is NO WARRANTY, to the extent permitted by law.
 
 EAPI=7
 
+_PYTHON_ALLOW_PY27=1
 PYTHON_COMPAT=( python2_7 )
 
 inherit autotools python-single-r1
@@ -31,6 +32,8 @@ REQUIRED_USE=$PYTHON_REQUIRED_USE
 
 S=$WORKDIR/$MY_P
 
+PATCHES=("$FILESDIR/$PV-no-mypaint-brushes.patch")
+
 src_prepare () {
        sed -i '/^libgimp/s|[^ ]*/lib\(gimp[^-]*\)-[^ ]*\.la|-l\1-2.0|' \
                plug-ins/pygimp/Makefile.am