]> git.draconx.ca Git - gentoo-draconx.git/blobdiff - dev-util/qcachegrind/qcachegrind-0.7.4.ebuild
qcachegrind: Enable build for Qt5.
[gentoo-draconx.git] / dev-util / qcachegrind / qcachegrind-0.7.4.ebuild
diff --git a/dev-util/qcachegrind/qcachegrind-0.7.4.ebuild b/dev-util/qcachegrind/qcachegrind-0.7.4.ebuild
deleted file mode 100644 (file)
index f11176d..0000000
+++ /dev/null
@@ -1,42 +0,0 @@
-EAPI=5
-
-inherit qt4-r2
-
-MY_P="kcachegrind-${PV}"
-
-DESCRIPTION="Qt4-based GUI frontend for Callgrind"
-HOMEPAGE="http://kcachegrind.sourceforge.net/"
-SRC_URI="http://kcachegrind.sourceforge.net/${MY_P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64"
-IUSE="dbus"
-
-DEPEND=">=dev-qt/qtgui-4.4
-       dbus? ( >=dev-qt/qtdbus-4.4 )"
-RDEPEND="${DEPEND}
-       media-gfx/graphviz"
-
-S="${WORKDIR}/${MY_P}"
-
-src_prepare() {
-       use dbus || PATCHES+=("${FILESDIR}/${PN}-disable-dbus.patch")
-
-       qt4-r2_src_prepare
-}
-
-src_configure() {
-       eqmake4 qcg.pro
-}
-
-src_install() {
-       dobin qcachegrind/qcachegrind
-       dobin cgview/cgview
-
-       newicon -s 48 kcachegrind/hi48-app-kcachegrind.png kcachegrind.png
-       newicon -s 32 kcachegrind/hi32-app-kcachegrind.png kcachegrind.png
-
-       insinto /usr/share/applications
-       doins qcachegrind/qcachegrind.desktop
-}