]> git.draconx.ca Git - gentoo-draconx.git/blobdiff - sci-electronics/lepton-eda/lepton-eda-1.9.11_p20200604.ebuild
Add ebuild for lepton-eda.
[gentoo-draconx.git] / sci-electronics / lepton-eda / lepton-eda-1.9.11_p20200604.ebuild
diff --git a/sci-electronics/lepton-eda/lepton-eda-1.9.11_p20200604.ebuild b/sci-electronics/lepton-eda/lepton-eda-1.9.11_p20200604.ebuild
new file mode 100644 (file)
index 0000000..fe109b2
--- /dev/null
@@ -0,0 +1,52 @@
+# Copyright © 2020 Nick Bowler
+# License GPLv3+: GNU General Public License version 3 or any later version.
+# This is free software: you are free to change and redistribute it.
+# There is NO WARRANTY, to the extent permitted by law.
+
+EAPI=7
+
+inherit xdg-utils
+
+MY_P=$PN-${PV%_p*}
+
+DESCRIPTION="Schematic capture and netlist utilities (fork of gEDA:gaf)"
+HOMEPAGE="https://github.com/lepton-eda/lepton-eda"
+SRC_URI="$HOMEPAGE/releases/download/${PV/_p/-}/$MY_P.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc nls stroke"
+
+RDEPEND=">=dev-scheme/guile-2.0
+       >=x11-libs/gtk+-2.24:2
+       nls? ( virtual/libintl )
+       stroke? ( dev-libs/libstroke )"
+DEPEND="$RDEPEND
+       doc? ( app-doc/doxygen )
+       nls? ( >=sys-devel/gettext-0.18 )
+       dev-util/desktop-file-utils
+       x11-misc/shared-mime-info
+       sys-apps/groff
+       virtual/pkgconfig"
+
+S=$WORKDIR/$MY_P
+
+src_configure () {
+       econf \
+               $(use_enable doc doxygen) \
+               $(use_enable nls) \
+               $(use_with stroke libstroke) \
+               --disable-update-xdg-database \
+               --disable-rpath
+}
+
+pkg_postinst () {
+       xdg_desktop_database_update
+       xdg_mimeinfo_database_update
+       xdg_icon_cache_update
+}
+
+pkg_postrm () {
+       pkg_postinst
+}