]> git.draconx.ca Git - gentoo-draconx.git/blobdiff - app-misc/ps2emu/ps2emu-1.0.1-r1.ebuild
app-misc/ps2emu: Update for EAPI 8.
[gentoo-draconx.git] / app-misc / ps2emu / ps2emu-1.0.1-r1.ebuild
similarity index 51%
rename from app-misc/ps2emu/ps2emu-1.0.1.ebuild
rename to app-misc/ps2emu/ps2emu-1.0.1-r1.ebuild
index d3070e98dabc6249ccfa147c07fd4cc8f13b3a09..f6ac1e5fdda5303afa215aec919f911028b0afeb 100644 (file)
@@ -1,24 +1,27 @@
-# Copyright © 2015 Nick Bowler
-# License GPLv3+: GNU General Public License version 3 or later.
+# Copyright © 2015, 2022 Nick Bowler
+# License GPLv3+: GNU General Public License version 3 or any later version.
+# This is free software: you are free to change and redistribute it.
 # There is NO WARRANTY, to the extent permitted by law.
 
-EAPI=5
+EAPI=8
 
 inherit autotools
 
 DESCRIPTION="Tools for recording and playing back PS/2 devices on Linux"
 HOMEPAGE="https://github.com/Lyude/ps2emu"
-SRC_URI="https://github.com/Lyude/ps2emu/archive/v1.0.1.tar.gz"
+SRC_URI="https://github.com/Lyude/ps2emu/archive/v$PV.tar.gz -> $P.tar.gz"
 
 LICENSE="GPL-2+"
 SLOT="0"
 KEYWORDS="~amd64"
 
 RDEPEND="dev-libs/glib:2"
-DEPEND="virtual/pkgconfig
-       $RDEPEND"
+DEPEND=$RDEPEND
+BEPEND="virtual/pkgconfig"
 
 src_prepare() {
        cp "$FILESDIR/userio.h" ps2emu-kmod/
+
+       default
        eautoreconf
 }