]> git.draconx.ca Git - gentoo-draconx.git/blobdiff - media-fonts/mplus-t-fonts/mplus-t-fonts-20140706-r1.ebuild
mplus-t-fonts: Update for newer fontforge.
[gentoo-draconx.git] / media-fonts / mplus-t-fonts / mplus-t-fonts-20140706-r1.ebuild
similarity index 61%
rename from media-fonts/mplus-t-fonts/mplus-t-fonts-20140706.ebuild
rename to media-fonts/mplus-t-fonts/mplus-t-fonts-20140706-r1.ebuild
index f97972d6ff4d7b097042ffc07f2f0874b10ec3ea..b820862c95c98705f12360c90007bfbccf0442ee 100644 (file)
@@ -1,8 +1,8 @@
-# Copyright © 2014 Nick Bowler
+# Copyright © 2014, 2018 Nick Bowler
 # License GPLv3+: GNU General Public License version 3 or later.
 # There is NO WARRANTY, to the extent permitted by law.
 
-EAPI=5
+EAPI=6
 PYTHON_COMPAT=( python2_7 )
 
 inherit python-any-r1 font
@@ -10,15 +10,19 @@ inherit python-any-r1 font
 SHA1=d180c0bfdd4e3911a18360b3ccacd5271441e240
 
 DESCRIPTION="Variant of the M+ fonts with enlarged CJK glyphs"
-SRC_URI="http://git.draconx.ca/gitweb/scripts.git/snapshot/$SHA1.tar.xz"
+SRC_URI="https://git.draconx.ca/gitweb/scripts.git/snapshot/$SHA1.tar.xz
+         -> scripts-$SHA1.tar.xz"
 
 LICENSE="WTFPL-2 mplus-fonts IPAfont"
 SLOT="0"
 KEYWORDS="~amd64"
 
-DEPEND="$PYTHON_DEPS
-       media-fonts/mplus-outline-fonts[ipafont]
-       media-gfx/fontforge[python]"
+DEPEND="$(python_gen_any_dep 'media-gfx/fontforge[python,${PYTHON_USEDEP}]')
+       media-fonts/mplus-outline-fonts[ipafont]"
+
+python_check_deps () {
+       has_version "media-gfx/fontforge[${PYTHON_USEDEP}]"
+}
 
 S=$WORKDIR/$SHA1
 MPLUSDIR=$EPREFIX/usr/share/fonts/mplus-outline-fonts
@@ -26,12 +30,12 @@ MPLUSDIR=$EPREFIX/usr/share/fonts/mplus-outline-fonts
 FONT_S=$S/inst
 FONT_SUFFIX=ttf
 
-pkg_setup() {
+pkg_setup () {
        python-any-r1_pkg_setup
        font_pkg_setup
 }
 
-src_compile() {
+src_compile () {
        ln -s "$MPLUSDIR"/*.ttf . || die
        python mplus-t-gen.py || die