]> git.draconx.ca Git - gentoo-draconx.git/blobdiff - sys-apps/vbetest/vbetest-0.10.ebuild
games-strategy/uplink: Update to work with latest gentoo repo.
[gentoo-draconx.git] / sys-apps / vbetest / vbetest-0.10.ebuild
index a589c22c820f12eafd2e28b0b8acb5d092333d83..566fc4ccd979099d6119c53394fd298f822b370f 100644 (file)
@@ -17,15 +17,16 @@ DEPEND="lrmi? ( =sys-libs/lrmi-${PV}* )
        !lrmi? ( dev-libs/libx86 )"
 
 src_prepare() {
+       epatch "${FILESDIR}/lrmi-${PV}-ldflags.patch"
        if ! use lrmi ; then
-               epatch "${FILESDIR}/${PN}-libx86.patch" || die
+               epatch "${FILESDIR}/${PN}-libx86.patch"
        else
-               epatch "${FILESDIR}/${PN}-sharedlrmi.patch" || die
+               epatch "${FILESDIR}/${PN}-sharedlrmi.patch"
        fi
 }
 
 src_compile() {
-       emake CC="$(tc-getCC)" CFLAGS="${CFLAGS}" vbetest
+       emake CC="$(tc-getCC)" CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}" vbetest
 }
 
 src_install() {