]> git.draconx.ca Git - gentoo-draconx.git/blobdiff - x11-base/xorg-server/xorg-server-9999.ebuild
xorg-server: Sync with X11 overlay and remove GLX patch.
[gentoo-draconx.git] / x11-base / xorg-server / xorg-server-9999.ebuild
index 44fa7764c8bed490622a9d595832863d423aaae6..47e3b80e0b0e6c7aafadc2ea6c6273c57d6501b1 100644 (file)
@@ -78,7 +78,10 @@ DEPEND="${RDEPEND}
        >=x11-proto/xineramaproto-1.1.3
        >=x11-proto/xproto-7.0.17
        dmx? ( >=x11-proto/dmxproto-2.2.99.1 )
-       doc? ( >=app-doc/doxygen-1.6.1 )
+       doc? (
+               >=app-doc/doxygen-1.6.1
+               app-text/xmlto
+       )
        !minimal? (
                >=x11-proto/xf86driproto-2.1.0
                >=x11-proto/dri2proto-2.1
@@ -100,7 +103,6 @@ EPATCH_SUFFIX="patch"
 PATCHES=(
        "${UPSTREAMED_PATCHES[@]}"
        "${FILESDIR}"/${PN}-disable-acpi.patch
-       "${FILESDIR}"/0001-glx-Prevent-NULL-context-deref-in-__glXGetDrawable.patch
        )
 
 pkg_setup() {
@@ -109,9 +111,11 @@ pkg_setup() {
        use minimal || ensure_a_server_is_building
 
        # localstatedir is used for the log location; we need to override the default
-       # from ebuild.sh
+       #       from ebuild.sh
        # sysconfdir is used for the xorg.conf location; same applies
-       # --enable-install-setuid needed because sparcs default off
+       #       --enable-install-setuid needed because sparcs default off
+       # NOTE: fop is used for doc generating ; and i have no idea if gentoo
+       #        package it somewhere
        CONFIGURE_OPTIONS="
                $(use_enable ipv6)
                $(use_enable dmx)
@@ -130,6 +134,7 @@ pkg_setup() {
                $(use_enable nptl glx-tls)
                $(use_enable udev config-udev)
                $(use_with doc doxygen)
+               $(use_with doc xmlto)
                --sysconfdir=/etc/X11
                --localstatedir=/var
                --enable-install-setuid
@@ -137,6 +142,7 @@ pkg_setup() {
                --with-xkb-output=/var/lib/xkb
                --disable-config-hal
                --without-dtrace
+               --without-fop
                --with-os-vendor=Gentoo
                ${conf_opts}"