]> git.draconx.ca Git - gentoo-draconx.git/blobdiff - media-fonts/mplus-t-fonts/mplus-t-fonts-20180128-r2.ebuild
media-fonts/mplus-t-fonts: Update for new python eclasses.
[gentoo-draconx.git] / media-fonts / mplus-t-fonts / mplus-t-fonts-20180128-r2.ebuild
similarity index 72%
rename from media-fonts/mplus-t-fonts/mplus-t-fonts-20180128-r1.ebuild
rename to media-fonts/mplus-t-fonts/mplus-t-fonts-20180128-r2.ebuild
index e05967b8fe947d199c0a5d460857e81a60ac421c..d98f46e053ebba77c842562acf493e8e1b740674 100644 (file)
@@ -1,9 +1,9 @@
-# Copyright © 2014, 2018-2019 Nick Bowler
+# Copyright © 2014, 2018-2020 Nick Bowler
 # License GPLv3+: GNU General Public License version 3 or later.
 # There is NO WARRANTY, to the extent permitted by law.
 
-EAPI=6
-PYTHON_COMPAT=( python2_7 python3_5 python3_6 )
+EAPI=7
+PYTHON_COMPAT=( python2_7 python3_{5..8} )
 
 inherit python-any-r1 font
 
@@ -17,11 +17,12 @@ LICENSE="WTFPL-2 mplus-fonts IPAfont"
 SLOT="0"
 KEYWORDS="~amd64 ~arm"
 
-DEPEND="$(python_gen_any_dep 'media-gfx/fontforge[python,${PYTHON_USEDEP}]')
-       media-fonts/mplus-outline-fonts[ipafont]"
+BDEPEND="media-fonts/mplus-outline-fonts[ipafont]
+       $(python_gen_any_dep \
+               'media-gfx/fontforge[python,${PYTHON_SINGLE_USEDEP}]')"
 
 python_check_deps () {
-       has_version "media-gfx/fontforge[${PYTHON_USEDEP}]"
+       has_version -b "media-gfx/fontforge[${PYTHON_SINGLE_USEDEP}]"
 }
 
 S=$WORKDIR/$SHA1