]> git.draconx.ca Git - gentoo-draconx.git/blob - app-portage/nullsync/nullsync-20170402-r4.ebuild
b61287c69c38da044f56cfddfe29ab532c73843e
[gentoo-draconx.git] / app-portage / nullsync / nullsync-20170402-r4.ebuild
1 # Copyright © 2016-2018,2020 Nick Bowler
2 # License GPLv3+: GNU General Public License version 3 or later.
3 # There is NO WARRANTY, to the extent permitted by law.
4
5 EAPI=7
6
7 PYTHON_COMPAT=( python2_7 python3_4 python3_5 python3_6 python3_7 python3_8 )
8 inherit distutils-r1
9
10 SHA1=2908f0f47314ce697a212a059e9e239031c713d4
11
12 DESCRIPTION="No-op sync module for portage"
13 SRC_URI="https://git.draconx.ca/gitweb/nullsync.git/snapshot/$SHA1.tar.xz -> $P.tar.xz"
14
15 LICENSE="GPL-2+"
16 SLOT="0"
17 KEYWORDS="~amd64 ~arm"
18 REQUIRED_USE=$PYTHON_REQUIRED_USE
19
20 RDEPEND=">=sys-apps/portage-2.2.21[$PYTHON_USEDEP]"
21 DEPEND="$RDEPEND
22         dev-python/setuptools[$PYTHON_USEDEP]"
23
24 S=$WORKDIR/$SHA1