]> git.draconx.ca Git - gentoo-draconx.git/blob - x11-base/xorg-server/xorg-server-9999.ebuild
64650f6b59c2a1348aff67df913ff14667c3d068
[gentoo-draconx.git] / x11-base / xorg-server / xorg-server-9999.ebuild
1 # Copyright 1999-2011 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 EAPI=4
6
7 XORG_DOC=doc
8 inherit xorg-2 multilib versionator
9 EGIT_REPO_URI="git://anongit.freedesktop.org/git/xorg/xserver"
10
11 DESCRIPTION="X.Org X servers"
12 KEYWORDS=""
13
14 IUSE_SERVERS="dmx kdrive xorg"
15 IUSE="${IUSE_SERVERS} ipv6 minimal nptl tslib +udev"
16
17 RDEPEND=">=app-admin/eselect-opengl-1.0.8
18         dev-libs/openssl
19         media-libs/freetype
20         >=x11-apps/iceauth-1.0.2
21         >=x11-apps/rgb-1.0.3
22         >=x11-apps/xauth-1.0.3
23         x11-apps/xkbcomp
24         >=x11-libs/libpciaccess-0.10.3
25         >=x11-libs/libXau-1.0.4
26         >=x11-libs/libXdmcp-1.0.2
27         >=x11-libs/libXfont-1.4.2
28         >=x11-libs/libxkbfile-1.0.4
29         >=x11-libs/pixman-0.21.8
30         >=x11-libs/xtrans-1.2.2
31         >=x11-misc/xbitmaps-1.0.1
32         >=x11-misc/xkeyboard-config-1.4
33         dmx? (
34                 x11-libs/libXt
35                 >=x11-libs/libdmx-1.0.99.1
36                 >=x11-libs/libX11-1.1.5
37                 >=x11-libs/libXaw-1.0.4
38                 >=x11-libs/libXext-1.0.99.4
39                 >=x11-libs/libXfixes-4.0.3
40                 >=x11-libs/libXi-1.2.99.1
41                 >=x11-libs/libXmu-1.0.3
42                 >=x11-libs/libXres-1.0.3
43                 >=x11-libs/libXtst-1.0.99.2
44         )
45         kdrive? (
46                 >=x11-libs/libXext-1.0.5
47                 x11-libs/libXv
48         )
49         !minimal? (
50                 >=x11-libs/libX11-1.1.5
51                 >=x11-libs/libXext-1.0.5
52                 >=media-libs/mesa-7.8_rc[nptl=]
53         )
54         tslib? ( >=x11-libs/tslib-1.0 x11-proto/xcalibrateproto )
55         udev? ( >=sys-fs/udev-150 )
56         >=x11-apps/xinit-1.3"
57
58 DEPEND="${RDEPEND}
59         sys-devel/flex
60         >=x11-proto/bigreqsproto-1.1.0
61         >=x11-proto/compositeproto-0.4
62         >=x11-proto/damageproto-1.1
63         >=x11-proto/fixesproto-4.1
64         >=x11-proto/fontsproto-2.0.2
65         >=x11-proto/glproto-1.4.11
66         >=x11-proto/inputproto-1.9.99.902
67         >=x11-proto/kbproto-1.0.3
68         >=x11-proto/randrproto-1.2.99.3
69         >=x11-proto/recordproto-1.13.99.1
70         >=x11-proto/renderproto-0.11
71         >=x11-proto/resourceproto-1.0.2
72         >=x11-proto/scrnsaverproto-1.1
73         >=x11-proto/trapproto-3.4.3
74         >=x11-proto/videoproto-2.2.2
75         >=x11-proto/xcmiscproto-1.2.0
76         >=x11-proto/xextproto-7.1.99
77         >=x11-proto/xf86dgaproto-2.0.99.1
78         >=x11-proto/xf86rushproto-1.1.2
79         >=x11-proto/xf86vidmodeproto-2.2.99.1
80         >=x11-proto/xineramaproto-1.1.3
81         >=x11-proto/xproto-7.0.17
82         dmx? ( >=x11-proto/dmxproto-2.2.99.1 )
83         !minimal? (
84                 >=x11-proto/xf86driproto-2.1.0
85                 >=x11-proto/dri2proto-2.3
86                 >=x11-libs/libdrm-2.4.20
87         )"
88
89 PDEPEND="
90         xorg? ( x11-base/xorg-drivers )"
91
92 REQUIRED_USE="!minimal? (
93                 || ( ${IUSE_SERVERS} )
94         )"
95
96 #UPSTREAMED_PATCHES=(
97 #       "${WORKDIR}/patches/"
98 #)
99
100 PATCHES=(
101         "${UPSTREAMED_PATCHES[@]}"
102         "${FILESDIR}"/${PN}-disable-acpi.patch
103         "${FILESDIR}"/${PN}-1.9-nouveau-default.patch
104         "${FILESDIR}"/0001-xaa-Free-the-scratch-pixmap-header-before-freeing-th.patch
105         "${FILESDIR}"/0002-Remove-the-cacheing-of-the-last-scratch-PixmapRec.patch
106         "${FILESDIR}"/0003-shm-Replace-open-coded-version-of-GetScratchPixmapHe.patch
107         "${FILESDIR}"/0004-shadow-Remove-unused-ModifyPixmapHeader-wrapping.patch
108 )
109
110 pkg_pretend() {
111         # older gcc is not supported
112         [[ $(gcc-major-version) -lt 4 ]] && \
113                 die "Sorry, but gcc earlier than 4.0 wont work for xorg-server."
114 }
115
116 pkg_setup() {
117         xorg-2_pkg_setup
118
119         # localstatedir is used for the log location; we need to override the default
120         #       from ebuild.sh
121         # sysconfdir is used for the xorg.conf location; same applies
122         #       --enable-install-setuid needed because sparcs default off
123         # NOTE: fop is used for doc generating ; and i have no idea if gentoo
124         #       package it somewhere
125         XORG_CONFIGURE_OPTIONS=(
126                 $(use_enable ipv6)
127                 $(use_enable dmx)
128                 $(use_enable kdrive)
129                 $(use_enable kdrive kdrive-kbd)
130                 $(use_enable kdrive kdrive-mouse)
131                 $(use_enable kdrive kdrive-evdev)
132                 $(use_enable tslib)
133                 $(use_enable tslib xcalibrate)
134                 $(use_enable !minimal xvfb)
135                 $(use_enable !minimal xnest)
136                 $(use_enable !minimal record)
137                 $(use_enable !minimal xfree86-utils)
138                 $(use_enable !minimal install-libxf86config)
139                 $(use_enable !minimal dri)
140                 $(use_enable !minimal dri2)
141                 $(use_enable !minimal glx)
142                 $(use_enable xorg)
143                 $(use_enable nptl glx-tls)
144                 $(use_enable udev config-udev)
145                 $(use_with doc doxygen)
146                 $(use_with doc xmlto)
147                 --sysconfdir=/etc/X11
148                 --localstatedir=/var
149                 --enable-install-setuid
150                 --with-fontrootdir=/usr/share/fonts
151                 --with-xkb-output=/var/lib/xkb
152                 --disable-config-hal
153                 --without-dtrace
154                 --without-fop
155                 --with-os-vendor=Gentoo
156         )
157
158         # Xorg-server requires includes from OS mesa which are not visible for
159         # users of binary drivers.
160         mkdir -p "${T}/mesa-symlinks/GL"
161         for i in gl glx glxmd glxproto glxtokens; do
162                 ln -s "${EROOT}usr/$(get_libdir)/opengl/xorg-x11/include/$i.h" "${T}/mesa-symlinks/GL/$i.h" || die
163         done
164         for i in glext glxext; do
165                 ln -s "${EROOT}usr/$(get_libdir)/opengl/global/include/$i.h" "${T}/mesa-symlinks/GL/$i.h" || die
166         done
167         append-cppflags "-I${T}/mesa-symlinks"
168 }
169
170 src_install() {
171         xorg-2_src_install
172
173         dynamic_libgl_install
174
175         server_based_install
176
177         if ! use minimal &&     use xorg; then
178                 # Install xorg.conf.example into docs
179                 dodoc "${AUTOTOOLS_BUILD_DIR}"/hw/xfree86/xorg.conf.example
180         fi
181
182         newinitd "${FILESDIR}"/xdm-setup.initd-1 xdm-setup
183         newinitd "${FILESDIR}"/xdm.initd-3 xdm
184         newconfd "${FILESDIR}"/xdm.confd-3 xdm
185
186         # install the @x11-module-rebuild set for Portage
187         insinto /usr/share/portage/config/sets
188         newins "${FILESDIR}"/xorg-sets.conf xorg.conf
189 }
190
191 pkg_postinst() {
192         # sets up libGL and DRI2 symlinks if needed (ie, on a fresh install)
193         eselect opengl set xorg-x11 --use-old
194
195         if [[ ${PV} != 9999 && $(get_version_component_range 2 ${REPLACING_VERSIONS}) != $(get_version_component_range 2 ${PV}) ]]; then
196                 elog "You should consider reading upgrade guide for this release:"
197                 elog "  http://www.gentoo.org/proj/en/desktop/x/x11/xorg-server-$(get_version_component_range 1-2)-upgrade-guide.xml"
198                 echo
199                 ewarn "You must rebuild all drivers if upgrading from <xorg-server-$(get_version_component_range 1-2)"
200                 ewarn "because the ABI changed. If you cannot start X because"
201                 ewarn "of module version mismatch errors, this is your problem."
202
203                 echo
204                 ewarn "You can generate a list of all installed packages in the x11-drivers"
205                 ewarn "category using this command:"
206                 ewarn " emerge portage-utils; qlist -I -C x11-drivers/"
207                 ewarn "or using sets from portage-2.2:"
208                 ewarn " emerge @x11-module-rebuild"
209         fi
210 }
211
212 pkg_postrm() {
213         # Get rid of module dir to ensure opengl-update works properly
214         if [[ -z ${REPLACED_BY_VERSION} && -e ${ROOT}/usr/$(get_libdir)/xorg/modules ]]; then
215                 rm -rf "${ROOT}"/usr/$(get_libdir)/xorg/modules
216         fi
217 }
218
219 dynamic_libgl_install() {
220         # next section is to setup the dynamic libGL stuff
221         ebegin "Moving GL files for dynamic switching"
222                 dodir /usr/$(get_libdir)/opengl/xorg-x11/extensions
223                 local x=""
224                 for x in "${D}"/usr/$(get_libdir)/xorg/modules/extensions/lib{glx,dri,dri2}*; do
225                         if [ -f ${x} -o -L ${x} ]; then
226                                 mv -f ${x} "${D}"/usr/$(get_libdir)/opengl/xorg-x11/extensions
227                         fi
228                 done
229         eend 0
230 }
231
232 server_based_install() {
233         if ! use xorg; then
234                 rm "${D}"/usr/share/man/man1/Xserver.1x \
235                         "${D}"/usr/$(get_libdir)/xserver/SecurityPolicy \
236                         "${D}"/usr/$(get_libdir)/pkgconfig/xorg-server.pc \
237                         "${D}"/usr/share/man/man1/Xserver.1x
238         fi
239 }