]> git.draconx.ca Git - gentoo-draconx.git/blob - app-crypt/jwk2pem/jwk2pem-0_p20221101.ebuild
2f656e6962f47e19aecb3cacf6f060d2c3bef809
[gentoo-draconx.git] / app-crypt / jwk2pem / jwk2pem-0_p20221101.ebuild
1 # Copyright © 2022 Nick Bowler
2 # License GPLv3+: GNU General Public License version 3 or any later version.
3 # This is free software: you are free to change and redistribute it.
4 # There is NO WARRANTY, to the extent permitted by law.
5
6 EAPI=8
7
8 PYTHON_COMPAT=( python3_10 )
9
10 inherit python-r1
11
12 SHA1=0c65729bc117c5350cd8a602e388a765a41bce4e
13
14 DESCRIPTION="Convert RSA keys from RFC7517 JWK format to PKCS#1 PEM format"
15 SRC_URI="https://git.draconx.ca/gitweb/scripts.git/snapshot/$SHA1.tar.xz -> scripts-$SHA1.tar.xz"
16
17 LICENSE="WTFPL-2"
18 SLOT="0"
19 KEYWORDS="~amd64"
20 REQUIRED_USE=$PYTHON_REQUIRED_USE
21
22 RDEPEND="$PYTHON_DEPS
23         dev-libs/openssl"
24 DEPEND=$PYTHON_DEPS
25
26 S=$WORKDIR/$SHA1
27
28 src_install () {
29         python_foreach_impl python_newscript jwk2pem.py jwk2pem
30 }