]> git.draconx.ca Git - gentoo-draconx.git/blob - dev-util/elftoaout/elftoaout-2.3.ebuild
0ab173708230eb6181729f5e17811795effcf49d
[gentoo-draconx.git] / dev-util / elftoaout / elftoaout-2.3.ebuild
1 # Copyright © 2022 Nick Bowler
2 # License GPLv3+: GNU General Public License version 3 or any later version.
3 # This is free software: you are free to change and redistribute it.
4 # There is NO WARRANTY, to the extent permitted by law.
5
6 EAPI=8
7
8 inherit toolchain-funcs
9
10 MY_PN=sparc-utils
11 MY_P=${MY_PN}_1.9
12
13 DESCRIPTION="ELF to a.out convertor for SPARC and SPARC64 bootstraps"
14 SRC_URI="http://archive.debian.org/debian-archive/debian/pool/main/s/$MY_PN/$MY_P.orig.tar.gz"
15
16 LICENSE="GPL-2+"
17 SLOT="0"
18 KEYWORDS="~amd64"
19
20 RDEPEND="!sys-apps/sparc-utils"
21
22 PATCHES=(
23         "$FILESDIR/$PN-build-rules.patch"
24         "$FILESDIR/$PN-lp64-fixes.patch"
25         "$FILESDIR/$PN-no-linux-elf.patch"
26 )
27
28 S=$WORKDIR/${MY_P/_/-}.orig
29
30 src_compile () {
31         emake -C $P CC=$(tc-getCC) CFLAGS="$CFLAGS" LDFLAGS="$LDFLAGS"
32 }
33
34 src_install () {
35         dobin $P/elftoaout
36         doman $P/elftoaout.1
37 }