]> git.draconx.ca Git - gentoo-draconx.git/blob - x11-base/xorg-server/xorg-server-1.7.5.901.ebuild
022a1f40aecb58146471756d66fee56a43c1776c
[gentoo-draconx.git] / x11-base / xorg-server / xorg-server-1.7.5.901.ebuild
1 # Copyright 1999-2010 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: /var/cvsroot/gentoo-x86/x11-base/xorg-server/xorg-server-1.7.5.901.ebuild,v 1.1 2010/03/07 19:07:17 chithanh Exp $
4
5 EAPI="2"
6
7 # Must be before x-modular eclass is inherited
8 #SNAPSHOT="yes"
9
10 inherit x-modular multilib versionator
11
12 EGIT_REPO_URI="git://anongit.freedesktop.org/git/xorg/xserver"
13
14 OPENGL_DIR="xorg-x11"
15
16 DESCRIPTION="X.Org X servers"
17 KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd"
18
19 IUSE_SERVERS="dmx kdrive xorg"
20 IUSE="${IUSE_SERVERS} tslib hal ipv6 minimal nptl sdl"
21 RDEPEND="hal? ( sys-apps/hal )
22         tslib? ( >=x11-libs/tslib-1.0 x11-proto/xcalibrateproto )
23         dev-libs/openssl
24         >=x11-libs/libXfont-1.3.3
25         >=x11-libs/xtrans-1.2.2
26         >=x11-libs/libXau-1.0.4
27         >=x11-libs/libxkbfile-1.0.4
28         >=x11-libs/libXdmcp-1.0.2
29         >=x11-libs/libpciaccess-0.10.3
30         >=x11-libs/pixman-0.15.20
31         media-libs/freetype
32         >=x11-misc/xbitmaps-1.0.1
33         >=x11-misc/xkeyboard-config-1.4
34         x11-apps/xkbcomp
35         >=x11-apps/iceauth-1.0.2
36         >=x11-apps/rgb-1.0.3
37         >=x11-apps/xauth-1.0.3
38         >=x11-apps/xinit-1.0.8-r3
39         >=app-admin/eselect-opengl-1.0.8
40         dmx? (
41                 x11-libs/libXt
42                 >=x11-libs/libdmx-1.0.99.1
43                 >=x11-libs/libX11-1.1.5
44                 >=x11-libs/libXaw-1.0.4
45                 >=x11-libs/libXext-1.0.5
46                 >=x11-libs/libXfixes-4.0.3
47                 >=x11-libs/libXi-1.2.99.1
48                 >=x11-libs/libXmu-1.0.3
49                 >=x11-libs/libXtst-1.0.3
50         )
51         !minimal? (
52                 >=x11-libs/libX11-1.1.5
53                 >=x11-libs/libXext-1.0.5
54                 >=x11-libs/libXres-1.0.3
55                 >=media-libs/mesa-7.4[nptl=]
56         )
57         >=x11-libs/libxkbui-1.0.2
58         kdrive? (
59                 >=x11-libs/libXext-1.0.5
60                 sdl? ( media-libs/libsdl ) )"
61         # Xres is dmx-dependent
62         # Xaw is dmx-dependent
63         # Xpm is dmx-dependent, pulls in Xt
64         # xkbcomp is launched at startup but not checked by ./configure
65
66 ## Deps that don't have a version in configure.ac but do here:
67 # x11-proto/resourceproto
68 # x11-proto/fontsproto
69 # x11-libs/libXau
70 # x11-libs/libXfont
71 # x11-libs/libXdmcp
72 # x11-libs/libXext
73 # x11-libs/libX11
74 # x11-libs/libXrender
75 # x11-libs/libXmu
76 # x11-libs/libXfixes
77 # x11-libs/libXtst
78 # x11-proto/xineramaproto
79 # x11-proto/dmxproto
80 ## Deps that are larger here than in configure.ac
81 # x11-libs/libpciaccess-0.8.0
82 #
83
84 DEPEND="${RDEPEND}
85         !!net-dialup/dtrace
86         sys-devel/flex
87         >=x11-proto/randrproto-1.2.99.3
88         >=x11-proto/renderproto-0.11
89         >=x11-proto/fixesproto-4.1
90         >=x11-proto/damageproto-1.1
91         >=x11-proto/xextproto-7.0.99.3
92         >=x11-proto/xproto-7.0.13
93         >=x11-proto/xf86dgaproto-2.0.99.1
94         >=x11-proto/xf86rushproto-1.1.2
95         >=x11-proto/xf86vidmodeproto-2.2.99.1
96         >=x11-proto/compositeproto-0.4
97         >=x11-proto/recordproto-1.13.99.1
98         >=x11-proto/resourceproto-1.0.2
99         >=x11-proto/videoproto-2.2.2
100         >=x11-proto/scrnsaverproto-1.1
101         >=x11-proto/trapproto-3.4.3
102         >=x11-proto/xineramaproto-1.1.3
103         >=x11-proto/fontsproto-2.0.2
104         >=x11-proto/kbproto-1.0.3
105         >=x11-proto/inputproto-1.9.99.902
106         >=x11-proto/bigreqsproto-1.1.0
107         >=x11-proto/xcmiscproto-1.2.0
108         >=x11-proto/glproto-1.4.9
109         dmx? ( >=x11-proto/dmxproto-2.2.99.1 )
110         !minimal? (
111                 >=x11-proto/xf86driproto-2.1.0
112                 >=x11-proto/dri2proto-2.1
113                 >=x11-libs/libdrm-2.3.0
114         )"
115
116 PDEPEND="xorg? ( >=x11-base/xorg-drivers-$(get_version_component_range 1-2) )"
117
118 EPATCH_FORCE="yes"
119 EPATCH_SUFFIX="patch"
120
121 # These have been sent upstream
122 UPSTREAMED_PATCHES=(
123         #"${WORKDIR}/patches/"
124         )
125
126 PATCHES=(
127         "${UPSTREAMED_PATCHES[@]}"
128         "${FILESDIR}/xfree86-Add-DontLie-server-flag.patch"
129         )
130
131 pkg_setup() {
132         use minimal || ensure_a_server_is_building
133
134         # SDL only available in kdrive build
135         if use kdrive && use sdl; then
136                 conf_opts="${conf_opts} --enable-xsdl"
137         else
138                 conf_opts="${conf_opts} --disable-xsdl"
139         fi
140
141         # localstatedir is used for the log location; we need to override the default
142         # from ebuild.sh
143         # sysconfdir is used for the xorg.conf location; same applies
144         # --enable-install-setuid needed because sparcs default off
145         CONFIGURE_OPTIONS="
146                 $(use_enable ipv6)
147                 $(use_enable dmx)
148                 $(use_enable kdrive)
149                 $(use_enable tslib)
150                 $(use_enable tslib xcalibrate)
151                 $(use_enable !minimal xvfb)
152                 $(use_enable !minimal xnest)
153                 $(use_enable !minimal record)
154                 $(use_enable !minimal xfree86-utils)
155                 $(use_enable !minimal install-libxf86config)
156                 $(use_enable !minimal dri)
157                 $(use_enable !minimal dri2)
158                 $(use_enable !minimal glx)
159                 $(use_enable xorg)
160                 $(use_enable nptl glx-tls)
161                 $(use_enable hal config-hal)
162                 --sysconfdir=/etc/X11
163                 --localstatedir=/var
164                 --enable-install-setuid
165                 --with-fontdir=/usr/share/fonts
166                 --with-xkb-output=/var/lib/xkb
167                 --without-dtrace
168                 ${conf_opts}"
169
170         # (#121394) Causes window corruption
171         filter-flags -fweb
172
173         # Incompatible with GCC 3.x SSP on x86, bug #244352
174         if use x86 ; then
175                 if [[ $(gcc-major-version) -lt 4 ]]; then
176                         filter-flags -fstack-protector
177                 fi
178         fi
179
180         OLD_IMPLEM="$(eselect opengl show)"
181         eselect opengl set ${OPENGL_DIR}
182 }
183
184 src_install() {
185         x-modular_src_install
186
187         dynamic_libgl_install
188
189         server_based_install
190
191         if ! use minimal &&     use xorg; then
192                 # Install xorg.conf.example (see bugs #151421 and #151670)
193                 insinto /etc/X11
194                 doins hw/xfree86/xorg.conf.example \
195                         || die "couldn't install xorg.conf.example"
196         fi
197 }
198
199 pkg_postinst() {
200         switch_opengl_implem
201
202         echo
203         ewarn "You must rebuild all drivers if upgrading from xorg-server 1.6"
204         ewarn "or earlier, because the ABI changed. If you cannot start X because"
205         ewarn "of module version mismatch errors, this is your problem."
206
207         echo
208         ewarn "You can generate a list of all installed packages in the x11-drivers"
209         ewarn "category using this command:"
210         ewarn "emerge portage-utils; qlist -I -C x11-drivers/"
211
212         ebeep 5
213         epause 10
214 }
215
216 pkg_postrm() {
217         # Get rid of module dir to ensure opengl-update works properly
218         if ! has_version x11-base/xorg-server; then
219                 if [[ -e ${ROOT}/usr/$(get_libdir)/xorg/modules ]]; then
220                         rm -rf "${ROOT}"/usr/$(get_libdir)/xorg/modules
221                 fi
222         fi
223 }
224
225 dynamic_libgl_install() {
226         # next section is to setup the dynamic libGL stuff
227         ebegin "Moving GL files for dynamic switching"
228                 dodir /usr/$(get_libdir)/opengl/${OPENGL_DIR}/extensions
229                 local x=""
230                 for x in "${D}"/usr/$(get_libdir)/xorg/modules/extensions/lib{glx,dri,dri2}*; do
231                         if [ -f ${x} -o -L ${x} ]; then
232                                 mv -f ${x} "${D}"/usr/$(get_libdir)/opengl/${OPENGL_DIR}/extensions
233                         fi
234                 done
235         eend 0
236 }
237
238 server_based_install() {
239         if ! use xorg; then
240                 rm "${D}"/usr/share/man/man1/Xserver.1x \
241                         "${D}"/usr/$(get_libdir)/xserver/SecurityPolicy \
242                         "${D}"/usr/$(get_libdir)/pkgconfig/xorg-server.pc \
243                         "${D}"/usr/share/man/man1/Xserver.1x
244         fi
245 }
246
247 switch_opengl_implem() {
248                 # Switch to the xorg implementation.
249                 # Use new opengl-update that will not reset user selected
250                 # OpenGL interface ...
251                 echo
252                 eselect opengl set ${OLD_IMPLEM}
253 }
254
255 ensure_a_server_is_building() {
256         for server in ${IUSE_SERVERS}; do
257                 use ${server} && return;
258         done
259         eerror "You need to specify at least one server to build."
260         eerror "Valid servers are: ${IUSE_SERVERS}."
261         die "No servers were specified to build."
262 }