]> git.draconx.ca Git - gentoo-draconx.git/blobdiff - app-portage/nullsync/nullsync-20170402.ebuild
app-portage/nullsync: Version bump.
[gentoo-draconx.git] / app-portage / nullsync / nullsync-20170402.ebuild
diff --git a/app-portage/nullsync/nullsync-20170402.ebuild b/app-portage/nullsync/nullsync-20170402.ebuild
new file mode 100644 (file)
index 0000000..55c7b3b
--- /dev/null
@@ -0,0 +1,24 @@
+# Copyright © 2016 Nick Bowler
+# License GPLv3+: GNU General Public License version 3 or later.
+# There is NO WARRANTY, to the extent permitted by law.
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_4 )
+inherit distutils-r1
+
+SHA1=2908f0f47314ce697a212a059e9e239031c713d4
+
+DESCRIPTION="No-op sync module for portage"
+SRC_URI="https://git.draconx.ca/gitweb/nullsync.git/snapshot/$SHA1.tar.xz
+         -> $P.tar.xz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm"
+
+RDEPEND=">=sys-apps/portage-2.2.21[$PYTHON_USEDEP]"
+DEPEND="$RDEPEND
+       dev-python/setuptools[$PYTHON_USEDEP]"
+
+S=$WORKDIR/$SHA1