]> git.draconx.ca Git - gentoo-draconx.git/blobdiff - sys-apps/vbetest/vbetest-0.10.ebuild
vbetest: Misc updates.
[gentoo-draconx.git] / sys-apps / vbetest / vbetest-0.10.ebuild
index 9e5b7ca40d712c8dd63470893b6995cccebee02c..a589c22c820f12eafd2e28b0b8acb5d092333d83 100644 (file)
@@ -1,8 +1,6 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: $
+EAPI=4
 
-inherit eutils
+inherit eutils toolchain-funcs
 
 S="${WORKDIR}/lrmi-${PV}"
 
@@ -13,26 +11,23 @@ SRC_URI="mirror://sourceforge/lrmi/lrmi-${PV}.tar.gz"
 LICENSE="MIT"
 SLOT="0"
 KEYWORDS="~x86 ~amd64"
-IUSE="+lrmi"
+IUSE="lrmi"
 
 DEPEND="lrmi? ( =sys-libs/lrmi-${PV}* )
        !lrmi? ( dev-libs/libx86 )"
 
-src_unpack() {
-       unpack "${A}"
-       cd "${S}"
-
+src_prepare() {
        if ! use lrmi ; then
-               epatch "${FILESDIR}/${PN}-libx86.patch"
+               epatch "${FILESDIR}/${PN}-libx86.patch" || die
        else
-               epatch "${FILESDIR}/${PN}-sharedlrmi.patch"
+               epatch "${FILESDIR}/${PN}-sharedlrmi.patch" || die
        fi
 }
 
 src_compile() {
-       emake CFLAGS="${CFLAGS}" vbetest || die
+       emake CC="$(tc-getCC)" CFLAGS="${CFLAGS}" vbetest
 }
 
 src_install() {
-       dobin vbetest || die "dobin"
+       dobin vbetest
 }