]> git.draconx.ca Git - gentoo-draconx.git/blobdiff - media-sound/regainer/regainer-20220503-r2.ebuild
media-sound/regainer: Update PYTHON_COMPAT and remove old.
[gentoo-draconx.git] / media-sound / regainer / regainer-20220503-r2.ebuild
diff --git a/media-sound/regainer/regainer-20220503-r2.ebuild b/media-sound/regainer/regainer-20220503-r2.ebuild
new file mode 100644 (file)
index 0000000..90debb2
--- /dev/null
@@ -0,0 +1,34 @@
+# Copyright 2018,2020-2022 Nick Bowler
+# License GPLv3+: GNU General Public License version 3 or any later version.
+# This is free software: you are free to change and redistribute it.
+# There is NO WARRANTY, to the extent permitted by law.
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..11} )
+
+inherit python-r1
+
+SHA1=c5195980cae0515346f520bafdb061ce6838a564
+
+DESCRIPTION="Simple tool which adds ReplayGain tags to your files"
+HOMEPAGE="https://github.com/kepstin/regainer"
+SRC_URI="https://github.com/kepstin/$PN/archive/$SHA1.tar.gz -> $P.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+REQUIRED_USE="$PYTHON_REQUIRED_USE"
+
+S=$WORKDIR/$PN-$SHA1
+
+RDEPEND="$PYTHON_DEPS
+       media-libs/mutagen[$PYTHON_USEDEP]
+       media-video/ffmpeg[encode]"
+DEPEND="$PYTHON_DEPS"
+
+src_install () {
+       default
+
+       python_foreach_impl python_newscript regainer.py regainer
+}