]> git.draconx.ca Git - gentoo-draconx.git/blobdiff - x11-libs/gtkextra/gtkextra-3.3.4.ebuild
Add ebuild for x11-libs/gtkextra.
[gentoo-draconx.git] / x11-libs / gtkextra / gtkextra-3.3.4.ebuild
diff --git a/x11-libs/gtkextra/gtkextra-3.3.4.ebuild b/x11-libs/gtkextra/gtkextra-3.3.4.ebuild
new file mode 100644 (file)
index 0000000..05d88c0
--- /dev/null
@@ -0,0 +1,28 @@
+# Copyright © 2021 Nick Bowler
+# License GPLv3+: GNU General Public License version 3 or any later version.
+# This is free software: you are free to change and redistribute it.
+# There is NO WARRANTY, to the extent permitted by law.
+
+EAPI=7
+
+DESCRIPTION="A useful set of widgets for creating GUIs for GTK+"
+HOMEPAGE="http://gtkextra.sourceforge.net"
+SRC_URI="mirror://sourceforge/$PN/$P.tar.gz"
+
+LICENSE="LGPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc +introspection"
+
+DEPEND="introspection? ( dev-libs/gobject-introspection:= )
+       x11-libs/gtk+:2"
+RDEPEND=$DEPEND
+
+src_configure () {
+       args=(
+               $(use_enable introspection)
+               --disable-glade
+               )
+
+       econf "${args[@]}"
+}