]> git.draconx.ca Git - gentoo-draconx.git/blob - sys-apps/vbetest/vbetest-0.10.ebuild
9e5b7ca40d712c8dd63470893b6995cccebee02c
[gentoo-draconx.git] / sys-apps / vbetest / vbetest-0.10.ebuild
1 # Copyright 1999-2008 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 inherit eutils
6
7 S="${WORKDIR}/lrmi-${PV}"
8
9 DESCRIPTION="Utility to display and test VESA BIOS Extensions (VBE) modes."
10 HOMEPAGE="http://www.sourceforge.net/projects/lrmi/"
11 SRC_URI="mirror://sourceforge/lrmi/lrmi-${PV}.tar.gz"
12
13 LICENSE="MIT"
14 SLOT="0"
15 KEYWORDS="~x86 ~amd64"
16 IUSE="+lrmi"
17
18 DEPEND="lrmi? ( =sys-libs/lrmi-${PV}* )
19         !lrmi? ( dev-libs/libx86 )"
20
21 src_unpack() {
22         unpack "${A}"
23         cd "${S}"
24
25         if ! use lrmi ; then
26                 epatch "${FILESDIR}/${PN}-libx86.patch"
27         else
28                 epatch "${FILESDIR}/${PN}-sharedlrmi.patch"
29         fi
30 }
31
32 src_compile() {
33         emake CFLAGS="${CFLAGS}" vbetest || die
34 }
35
36 src_install() {
37         dobin vbetest || die "dobin"
38 }