]> git.draconx.ca Git - gentoo-draconx.git/blob - x11-base/xorg-server/xorg-server-9999.ebuild
81b83d4fc599038274a89852cd9febc1530890bd
[gentoo-draconx.git] / x11-base / xorg-server / xorg-server-9999.ebuild
1 # Copyright 1999-2011 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 EAPI=4
6
7 XORG_DOC=doc
8 inherit xorg-2 multilib versionator
9 EGIT_REPO_URI="git://anongit.freedesktop.org/git/xorg/xserver"
10
11 DESCRIPTION="X.Org X servers"
12 KEYWORDS=""
13
14 IUSE_SERVERS="dmx kdrive xorg"
15 IUSE="${IUSE_SERVERS} ipv6 minimal nptl tslib +udev"
16
17 RDEPEND=">=app-admin/eselect-opengl-1.0.8
18         dev-libs/openssl
19         media-libs/freetype
20         >=x11-apps/iceauth-1.0.2
21         >=x11-apps/rgb-1.0.3
22         >=x11-apps/xauth-1.0.3
23         x11-apps/xkbcomp
24         >=x11-libs/libpciaccess-0.10.3
25         >=x11-libs/libXau-1.0.4
26         >=x11-libs/libXdmcp-1.0.2
27         >=x11-libs/libXfont-1.4.2
28         >=x11-libs/libxkbfile-1.0.4
29         >=x11-libs/pixman-0.21.8
30         >=x11-libs/xtrans-1.2.2
31         >=x11-misc/xbitmaps-1.0.1
32         >=x11-misc/xkeyboard-config-1.4
33         dmx? (
34                 x11-libs/libXt
35                 >=x11-libs/libdmx-1.0.99.1
36                 >=x11-libs/libX11-1.1.5
37                 >=x11-libs/libXaw-1.0.4
38                 >=x11-libs/libXext-1.0.99.4
39                 >=x11-libs/libXfixes-4.0.3
40                 >=x11-libs/libXi-1.2.99.1
41                 >=x11-libs/libXmu-1.0.3
42                 >=x11-libs/libXres-1.0.3
43                 >=x11-libs/libXtst-1.0.99.2
44         )
45         kdrive? (
46                 >=x11-libs/libXext-1.0.5
47                 x11-libs/libXv
48         )
49         !minimal? (
50                 >=x11-libs/libX11-1.1.5
51                 >=x11-libs/libXext-1.0.5
52                 >=media-libs/mesa-7.8_rc[nptl=]
53         )
54         tslib? ( >=x11-libs/tslib-1.0 x11-proto/xcalibrateproto )
55         udev? ( >=sys-fs/udev-150 )
56         >=x11-apps/xinit-1.3"
57
58 DEPEND="${RDEPEND}
59         sys-devel/flex
60         >=x11-proto/bigreqsproto-1.1.0
61         >=x11-proto/compositeproto-0.4
62         >=x11-proto/damageproto-1.1
63         >=x11-proto/fixesproto-4.1
64         >=x11-proto/fontsproto-2.0.2
65         >=x11-proto/glproto-1.4.11
66         >=x11-proto/inputproto-1.9.99.902
67         >=x11-proto/kbproto-1.0.3
68         >=x11-proto/randrproto-1.2.99.3
69         >=x11-proto/recordproto-1.13.99.1
70         >=x11-proto/renderproto-0.11
71         >=x11-proto/resourceproto-1.0.2
72         >=x11-proto/scrnsaverproto-1.1
73         >=x11-proto/trapproto-3.4.3
74         >=x11-proto/videoproto-2.2.2
75         >=x11-proto/xcmiscproto-1.2.0
76         >=x11-proto/xextproto-7.1.99
77         >=x11-proto/xf86dgaproto-2.0.99.1
78         >=x11-proto/xf86rushproto-1.1.2
79         >=x11-proto/xf86vidmodeproto-2.2.99.1
80         >=x11-proto/xineramaproto-1.1.3
81         >=x11-proto/xproto-7.0.17
82         dmx? ( >=x11-proto/dmxproto-2.2.99.1 )
83         !minimal? (
84                 >=x11-proto/xf86driproto-2.1.0
85                 >=x11-proto/dri2proto-2.3
86                 >=x11-libs/libdrm-2.4.20
87         )"
88
89 PDEPEND="
90         xorg? ( x11-base/xorg-drivers )"
91
92 REQUIRED_USE="!minimal? (
93                 || ( ${IUSE_SERVERS} )
94         )"
95
96 #UPSTREAMED_PATCHES=(
97 #       "${WORKDIR}/patches/"
98 #)
99
100 PATCHES=(
101         "${UPSTREAMED_PATCHES[@]}"
102         "${FILESDIR}"/${PN}-disable-acpi.patch
103         "${FILESDIR}"/${PN}-1.9-nouveau-default.patch
104         "${FILESDIR}"/0001-xfree86-Add-DontLie-server-flag.patch
105         "${FILESDIR}"/0001-xaa-Free-the-scratch-pixmap-header-before-freeing-th.patch
106         "${FILESDIR}"/0002-Remove-the-cacheing-of-the-last-scratch-PixmapRec.patch
107         "${FILESDIR}"/0003-shm-Replace-open-coded-version-of-GetScratchPixmapHe.patch
108         "${FILESDIR}"/0004-shadow-Remove-unused-ModifyPixmapHeader-wrapping.patch
109 )
110
111 pkg_pretend() {
112         # older gcc is not supported
113         [[ $(gcc-major-version) -lt 4 ]] && \
114                 die "Sorry, but gcc earlier than 4.0 wont work for xorg-server."
115 }
116
117 pkg_setup() {
118         xorg-2_pkg_setup
119
120         # localstatedir is used for the log location; we need to override the default
121         #       from ebuild.sh
122         # sysconfdir is used for the xorg.conf location; same applies
123         #       --enable-install-setuid needed because sparcs default off
124         # NOTE: fop is used for doc generating ; and i have no idea if gentoo
125         #       package it somewhere
126         XORG_CONFIGURE_OPTIONS=(
127                 $(use_enable ipv6)
128                 $(use_enable dmx)
129                 $(use_enable kdrive)
130                 $(use_enable kdrive kdrive-kbd)
131                 $(use_enable kdrive kdrive-mouse)
132                 $(use_enable kdrive kdrive-evdev)
133                 $(use_enable tslib)
134                 $(use_enable tslib xcalibrate)
135                 $(use_enable !minimal xvfb)
136                 $(use_enable !minimal xnest)
137                 $(use_enable !minimal record)
138                 $(use_enable !minimal xfree86-utils)
139                 $(use_enable !minimal install-libxf86config)
140                 $(use_enable !minimal dri)
141                 $(use_enable !minimal dri2)
142                 $(use_enable !minimal glx)
143                 $(use_enable xorg)
144                 $(use_enable nptl glx-tls)
145                 $(use_enable udev config-udev)
146                 $(use_with doc doxygen)
147                 $(use_with doc xmlto)
148                 --sysconfdir=/etc/X11
149                 --localstatedir=/var
150                 --enable-install-setuid
151                 --with-fontrootdir=/usr/share/fonts
152                 --with-xkb-output=/var/lib/xkb
153                 --disable-config-hal
154                 --without-dtrace
155                 --without-fop
156                 --with-os-vendor=Gentoo
157         )
158
159         # Xorg-server requires includes from OS mesa which are not visible for
160         # users of binary drivers.
161         mkdir -p "${T}/mesa-symlinks/GL"
162         for i in gl glx glxmd glxproto glxtokens; do
163                 ln -s "${EROOT}usr/$(get_libdir)/opengl/xorg-x11/include/$i.h" "${T}/mesa-symlinks/GL/$i.h" || die
164         done
165         for i in glext glxext; do
166                 ln -s "${EROOT}usr/$(get_libdir)/opengl/global/include/$i.h" "${T}/mesa-symlinks/GL/$i.h" || die
167         done
168         append-cppflags "-I${T}/mesa-symlinks"
169 }
170
171 src_install() {
172         xorg-2_src_install
173
174         dynamic_libgl_install
175
176         server_based_install
177
178         if ! use minimal &&     use xorg; then
179                 # Install xorg.conf.example into docs
180                 dodoc "${AUTOTOOLS_BUILD_DIR}"/hw/xfree86/xorg.conf.example
181         fi
182
183         newinitd "${FILESDIR}"/xdm-setup.initd-1 xdm-setup
184         newinitd "${FILESDIR}"/xdm.initd-3 xdm
185         newconfd "${FILESDIR}"/xdm.confd-3 xdm
186
187         # install the @x11-module-rebuild set for Portage
188         insinto /usr/share/portage/config/sets
189         newins "${FILESDIR}"/xorg-sets.conf xorg.conf
190 }
191
192 pkg_postinst() {
193         # sets up libGL and DRI2 symlinks if needed (ie, on a fresh install)
194         eselect opengl set xorg-x11 --use-old
195
196         if [[ ${PV} != 9999 && $(get_version_component_range 2 ${REPLACING_VERSIONS}) != $(get_version_component_range 2 ${PV}) ]]; then
197                 elog "You should consider reading upgrade guide for this release:"
198                 elog "  http://www.gentoo.org/proj/en/desktop/x/x11/xorg-server-$(get_version_component_range 1-2)-upgrade-guide.xml"
199                 echo
200                 ewarn "You must rebuild all drivers if upgrading from <xorg-server-$(get_version_component_range 1-2)"
201                 ewarn "because the ABI changed. If you cannot start X because"
202                 ewarn "of module version mismatch errors, this is your problem."
203
204                 echo
205                 ewarn "You can generate a list of all installed packages in the x11-drivers"
206                 ewarn "category using this command:"
207                 ewarn " emerge portage-utils; qlist -I -C x11-drivers/"
208                 ewarn "or using sets from portage-2.2:"
209                 ewarn " emerge @x11-module-rebuild"
210         fi
211 }
212
213 pkg_postrm() {
214         # Get rid of module dir to ensure opengl-update works properly
215         if [[ -z ${REPLACED_BY_VERSION} && -e ${ROOT}/usr/$(get_libdir)/xorg/modules ]]; then
216                 rm -rf "${ROOT}"/usr/$(get_libdir)/xorg/modules
217         fi
218 }
219
220 dynamic_libgl_install() {
221         # next section is to setup the dynamic libGL stuff
222         ebegin "Moving GL files for dynamic switching"
223                 dodir /usr/$(get_libdir)/opengl/xorg-x11/extensions
224                 local x=""
225                 for x in "${D}"/usr/$(get_libdir)/xorg/modules/extensions/lib{glx,dri,dri2}*; do
226                         if [ -f ${x} -o -L ${x} ]; then
227                                 mv -f ${x} "${D}"/usr/$(get_libdir)/opengl/xorg-x11/extensions
228                         fi
229                 done
230         eend 0
231 }
232
233 server_based_install() {
234         if ! use xorg; then
235                 rm "${D}"/usr/share/man/man1/Xserver.1x \
236                         "${D}"/usr/$(get_libdir)/xserver/SecurityPolicy \
237                         "${D}"/usr/$(get_libdir)/pkgconfig/xorg-server.pc \
238                         "${D}"/usr/share/man/man1/Xserver.1x
239         fi
240 }