]> git.draconx.ca Git - gentoo-draconx.git/blob - games-action/cavestory+/cavestory+-20111221.ebuild
Add cavestory+ ebuild.
[gentoo-draconx.git] / games-action / cavestory+ / cavestory+-20111221.ebuild
1 EAPI=3
2
3 inherit eutils games
4
5 MY_P="cavestoryplus-linux-1324519044"
6
7 DESCRIPTION="An updated version of Cave Story by Studio Pixel"
8 HOMEPAGE="http://www.nicalis.com/games.php?game=cavestory"
9 SRC_URI="${MY_P}.tar.gz"
10 RESTRICT="fetch"
11
12 QA_PRESTRIPPED="${GAMES_PREFIX_OPT}/${PN}/CaveStory+"'\(_64\)\?'
13
14 LICENSE="as-is"
15 SLOT="0"
16 KEYWORDS="-* ~amd64 ~x86"
17 IUSE=""
18
19 DEPEND="media-gfx/imagemagick[png]"
20 RDEPEND="media-libs/libsdl[opengl]"
21
22 S="${WORKDIR}/CaveStory+"
23
24 pkg_nofetch() {
25         ewarn
26         ewarn "Download ${A} to ${DISTDIR}."
27         ewarn
28 }
29
30 src_compile() {
31         convert "data/icon.bmp" "${PN}.png" || die "failed to convert icon."
32 }
33
34 src_install() {
35         local dir="${GAMES_PREFIX_OPT}/${PN}"
36         local exe="CaveStory+$(usex amd64 '_64' '')"
37
38         exeinto "${dir}"
39         doexe "CaveStory+$(usex amd64 '_64' '')"
40
41         insinto "${dir}"
42         doins -r data
43
44         doicon "${PN}.png"
45         make_desktop_entry "${PN}" "Cave Story+"
46         games_make_wrapper "${PN}" "${dir}/${exe}" "${dir}"
47
48         prepgamesdirs
49 }