]> git.draconx.ca Git - gentoo-fixes.git/blobdiff - media-sound/picard/picard-2.1.3.ebuild
media-sound/picard: Bump to 2.1.3.
[gentoo-fixes.git] / media-sound / picard / picard-2.1.3.ebuild
diff --git a/media-sound/picard/picard-2.1.3.ebuild b/media-sound/picard/picard-2.1.3.ebuild
new file mode 100644 (file)
index 0000000..e12df59
--- /dev/null
@@ -0,0 +1,83 @@
+# Copyright © 2018-2019 Nick Bowler
+# License GPLv2+: GNU General Public License version 2 or later.
+# This is free software: you are free to change and redistribute it.
+# There is NO WARRANTY, to the extent permitted by law.
+#
+# This a modified version of the original ebuild from Gentoo GNU/Linux,
+# covered by the following copyright and permission notice:
+#
+#   Copyright 1999-2018 Gentoo Foundation
+#   Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python3_{5,6} )
+DISTUTILS_SINGLE_IMPL=1
+DISABLE_AUTOFORMATTING=true
+
+inherit distutils-r1 gnome2-utils readme.gentoo-r1 xdg-utils
+
+DESCRIPTION="A cross-platform music tagger"
+HOMEPAGE="https://picard.musicbrainz.org"
+SRC_URI="https://github.com/metabrainz/$PN/archive/release-$PV.tar.gz -> $P.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="nls"
+
+RDEPEND="dev-python/PyQt5[declarative,gui,network,widgets,${PYTHON_USEDEP}]
+       >=media-libs/mutagen-1.38"
+DEPEND="$RDEPEND
+       nls? ( dev-qt/linguist-tools:5 )"
+
+RESTRICT="test" # doesn't work with ebuilds
+
+S=$WORKDIR/$PN-release-$PV
+
+python_compile() {
+       local build_args=(
+               --disable-autoupdate
+       )
+       if ! use nls; then
+               build_args+=( --disable-locales )
+       fi
+       distutils-r1_python_compile ${build_args[@]}
+}
+
+python_install() {
+       local install_args=(
+               --disable-autoupdate
+               --skip-build
+       )
+       if ! use nls; then
+               install_args+=( --disable-locales )
+       fi
+       distutils-r1_python_install ${install_args[@]}
+}
+
+python_install_all() {
+       distutils-r1_python_install_all
+
+       local DOC_CONTENTS="Install optional package media-libs/chromaprint[tools] to enable
+calculation and lookup of AcoustID fingerprints.
+
+Install optional package dev-python/python-discid to enable
+calculation and lookup of compact disc identifiers (disc IDs).
+
+If you are upgrading Picard and it does not start, try removing
+Picard's settings:
+       rm ~/.config/MusicBrainz/Picard.conf"
+       readme.gentoo_create_doc
+}
+
+pkg_postinst() {
+       readme.gentoo_print_elog
+       xdg_desktop_database_update
+       gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+       xdg_desktop_database_update
+       gnome2_icon_cache_update
+}