]> git.draconx.ca Git - gentoo-fixes.git/blobdiff - media-plugins/gimp-resynthesizer/gimp-resynthesizer-2.0.3-r3.ebuild
media-plugins/gimp-resynthesizer: Resurrect.
[gentoo-fixes.git] / media-plugins / gimp-resynthesizer / gimp-resynthesizer-2.0.3-r3.ebuild
diff --git a/media-plugins/gimp-resynthesizer/gimp-resynthesizer-2.0.3-r3.ebuild b/media-plugins/gimp-resynthesizer/gimp-resynthesizer-2.0.3-r3.ebuild
new file mode 100644 (file)
index 0000000..fc63752
--- /dev/null
@@ -0,0 +1,34 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit autotools python-single-r1
+
+MY_PN="${PN#gimp-}"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Suite of GIMP plugins for texture synthesis"
+HOMEPAGE="https://github.com/bootchk/resynthesizer"
+SRC_URI="https://github.com/bootchk/resynthesizer/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+REQUIRED_USE=${PYTHON_REQUIRED_USE}
+
+DEPEND="media-gfx/gimp
+       virtual/pkgconfig
+       ${PYTHON_DEPS}"
+RDEPEND="media-gfx/gimp[python(-),${PYTHON_SINGLE_USEDEP}]
+       ${PYTHON_DEPS}"
+
+S="${WORKDIR}/${MY_P}"
+
+src_prepare() {
+       default
+       eautoreconf
+}